Initial refactoring merge
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
index 739e672..fe33031 100644 (file)
@@ -1,10 +1,15 @@
+%define major 3
+%define minor 0
+%define patchlevel 1
+
 Name:       tel-plugin-indicator
 Summary:    Telephony Indicator plugin
-Version:    0.1.7
-Release:    2
+Version:        %{major}.%{minor}.%{patchlevel}
+Release:    1
 Group:      System/Libraries
-License:    Apache
+License:    Apache-2.0
 Source0:    tel-plugin-indicator-%{version}.tar.gz
+Source1001:    tel-plugin-indicator.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  cmake
@@ -17,6 +22,7 @@ Telephony Indicator plugin
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 %cmake .
@@ -30,9 +36,10 @@ make %{?jobs:-j%jobs}
 %install
 %make_install
 mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-%manifest tel-plugin-indicator.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/telephony/plugins/indicator-plugin*
-/usr/share/license/tel-plugin-indicator
+/usr/share/license/%{name}