Build excluded on tv emul
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
old mode 100755 (executable)
new mode 100644 (file)
index 33b46db..8d938d0
@@ -1,6 +1,6 @@
 %define major 0
 %define minor 1
-%define patchlevel 62
+%define patchlevel 69
 
 Name:           tel-plugin-indicator
 Version:        %{major}.%{minor}.%{patchlevel}
@@ -9,11 +9,14 @@ License:        Apache-2.0
 Summary:        Telephony Indicator plugin
 Group:          System/Libraries
 Source0:        tel-plugin-indicator-%{version}.tar.gz
+
+%if "%{profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
 BuildRequires:  cmake
-BuildRequires:  pkgconfig(deviced)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(tcore)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
@@ -27,17 +30,15 @@ Telephony Indicator plugin
 %build
 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
 
-%cmake . -DVERSION=$versionint \
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DLIB_INSTALL_DIR=%{_libdir} \
+       -DVERSION=$versionint \
 
 make %{?_smp_mflags}
 
 %post
 /sbin/ldconfig
 
-##setting vconf key##
-vconftool set -t bool memory/testmode/fast_dormancy 0 -i -f -s telephony_framework::vconf
-vconftool set -t bool memory/testmode/fast_dormancy2 0 -i -f -s telephony_framework::vconf
-
 %postun -p /sbin/ldconfig
 
 %install
@@ -47,6 +48,6 @@ cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
 %manifest tel-plugin-indicator.manifest
-%defattr(-,root,root,-)
+%defattr(644,system,system,-)
 %{_libdir}/telephony/plugins/indicator-plugin*
 /usr/share/license/%{name}