Modify uid/gid from system to root
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
old mode 100755 (executable)
new mode 100644 (file)
index 6977d77..79546a5
@@ -1,6 +1,6 @@
 %define major 0
 %define minor 1
-%define patchlevel 67
+%define patchlevel 70
 
 Name:           tel-plugin-indicator
 Version:        %{major}.%{minor}.%{patchlevel}
@@ -9,6 +9,11 @@ License:        Apache-2.0
 Summary:        Telephony Indicator plugin
 Group:          System/Libraries
 Source0:        tel-plugin-indicator-%{version}.tar.gz
+
+%if "%{profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
@@ -43,6 +48,6 @@ cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
 %manifest tel-plugin-indicator.manifest
-%defattr(644,system,system,-)
+%defattr(644,root,root,-)
 %{_libdir}/telephony/plugins/indicator-plugin*
 /usr/share/license/%{name}