Fix memory leak issue
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
old mode 100755 (executable)
new mode 100644 (file)
index aada3ac..1cec727
@@ -1,34 +1,38 @@
-%define major 3
-%define minor 0
-%define patchlevel 1
+%define major 0
+%define minor 1
+%define patchlevel 72
 
-Name:       tel-plugin-indicator
-Summary:    Telephony Indicator plugin
+Name:           tel-plugin-indicator
 Version:        %{major}.%{minor}.%{patchlevel}
-Release:    1
-Group:      System/Libraries
-License:    Apache-2.0
-Source0:    tel-plugin-indicator-%{version}.tar.gz
-Source1001:    tel-plugin-indicator.manifest
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
+Release:        5
+License:        Apache-2.0
+Summary:        Telephony Indicator plugin
+Group:          System/Libraries
+Source0:        tel-plugin-indicator-%{version}.tar.gz
+
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(tcore)
-BuildRequires:  pkgconfig(tel-headers)
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
 
 %description
 Telephony Indicator plugin
 
 %prep
 %setup -q
-cp %{SOURCE1001} .
 
 %build
-%cmake .
-make %{?jobs:-j%jobs}
+versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
+
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DLIB_INSTALL_DIR=%{_libdir} \
+       -DVERSION=$versionint \
+
+make %{?_smp_mflags}
 
-%post 
+%post
 /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
@@ -39,7 +43,7 @@ mkdir -p %{buildroot}/usr/share/license
 cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-%manifest %{name}.manifest
-%defattr(-,root,root,-)
+%manifest tel-plugin-indicator.manifest
+%defattr(644,root,root,-)
 %{_libdir}/telephony/plugins/indicator-plugin*
 /usr/share/license/%{name}