Apply secure-storage data migration
[platform/core/telephony/tel-plugin-imc.git] / packaging / tel-plugin-imc.spec
index bd474ba..f0a0f5a 100755 (executable)
@@ -1,7 +1,6 @@
 %define major 0
 %define minor 1
-%define patchlevel 69
-
+%define patchlevel 92
 
 Name:             tel-plugin-imc
 Version:          %{major}.%{minor}.%{patchlevel}
@@ -17,6 +16,7 @@ BuildRequires:    pkgconfig(tcore)
 BuildRequires:    pkgconfig(db-util)
 BuildRequires:    pkgconfig(vconf)
 BuildRequires:    pkgconfig(libxml-2.0)
+BuildRequires:    pkgconfig(key-manager)
 Requires(post):   /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
@@ -27,28 +27,12 @@ IMC plugin for telephony
 %setup -q
 
 %build
-%cmake .
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DLIB_INSTALL_DIR=%{_libdir}
 make %{?_smp_mflags}
 
 %post
 /sbin/ldconfig
-mkdir -p /opt/dbspace
-
-if [ ! -f /opt/dbspace/.mcc_mnc_oper_list.db ]
-then
-       sqlite3 /opt/dbspace/.mcc_mnc_oper_list.db < /tmp/mcc_mnc_oper_list.sql
-fi
-
-rm -f /tmp/mcc_mnc_oper_list.sql
-
-if [ -f /opt/dbspace/.mcc_mnc_oper_list.db ]
-then
-       chmod 600 /opt/dbspace/.mcc_mnc_oper_list.db
-fi
-if [ -f /opt/dbspace/.mcc_mnc_oper_list.db-journal ]
-then
-       chmod 644 /opt/dbspace/.mcc_mnc_oper_list.db-journal
-fi
 
 %postun -p /sbin/ldconfig
 
@@ -58,9 +42,6 @@ mkdir -p %{buildroot}/usr/share/license
 cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-
-%defattr(-,root,root,-)
-
+%defattr(644,system,system,-)
 %{_libdir}/telephony/plugins/modems/*
-/tmp/mcc_mnc_oper_list.sql
 /usr/share/license/%{name}