Fix svace issue
[platform/core/telephony/tel-plugin-database.git] / packaging / tel-plugin-database.spec
index c23004d..f9e2f71 100644 (file)
@@ -1,6 +1,6 @@
 %define major 0
 %define minor 1
-%define patchlevel 24
+%define patchlevel 47
 
 Name:           tel-plugin-database
 Version:        %{major}.%{minor}.%{patchlevel}
@@ -10,16 +10,34 @@ Summary:        Telephony DataBase storage plugin
 Group:          System/Libraries
 Source0:        tel-plugin-database-%{version}.tar.gz
 BuildRequires:  cmake
-BuildRequires:  pkgconfig(db-util)
+BuildRequires:  pkgconfig(sqlite3)
+BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(tcore)
 BuildRequires:  pkgconfig(libtzplatform-config)
+BuildRequires:  pkgconfig(capi-system-info)
+Requires:      security-config
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
 %description
 Telephony DataBase storage plugin
 
+%package -n libtfeature
+Summary:        Telephony Feature Library
+Group:          Development/Libraries
+
+%description -n libtfeature
+Telephony Feature Library
+
+%package -n libtfeature-devel
+Summary:        Telephony Feature Library (devel)
+Group:          Development/Libraries
+Requires:              libtfeature
+
+%description -n libtfeature-devel
+Telephony Feature Library (devel)
+
 %prep
 %setup -q
 
@@ -45,8 +63,10 @@ rm -f /tmp/mcc_mnc_oper_list.sql
 
 chmod 600 %TZ_SYS_DB/.mcc_mnc_oper_list.db
 chown telephony:telephony %TZ_SYS_DB/.mcc_mnc_oper_list.db
+chsmack -a System %TZ_SYS_DB/.mcc_mnc_oper_list.db
 chmod 644 %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
 chown telephony:telephony %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
+chsmack -a System %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
 
 %if 0%{?sec_product_feature_telephony_cdma}
        rm -f %TZ_SYS_DB/.mcc_sid_list.db
@@ -54,22 +74,36 @@ chown telephony:telephony %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
        rm -f /tmp/mcc_sid_list.sql
        chmod 600 %TZ_SYS_DB/.mcc_sid_list.db
        chown telephony:telephony %TZ_SYS_DB/.mcc_mnc_oper_list.db
+       chsmack -a System %TZ_SYS_DB/.mcc_mnc_oper_list.db
        chmod 644 %TZ_SYS_DB/.mcc_sid_list.db-journal
        chown telephony:telephony %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
+       chsmack -a System %TZ_SYS_DB/.mcc_mnc_oper_list.db-journal
 %endif
 
 %postun -p /sbin/ldconfig
 
 %install
 %make_install
-mkdir -p %{buildroot}%{_datadir}/license
 
 %files
-%defattr(644,system,system,-)
+%manifest %{name}.manifest
+%defattr(644,root,root,-)
 /tmp/mcc_mnc_oper_list.sql
 %if 0%{?sec_product_feature_telephony_cdma}
        /tmp/mcc_sid_list.sql
 %endif
 #%doc COPYING
 %{_libdir}/telephony/plugins/db-plugin*
-%{_datadir}/license/tel-plugin-database
+/opt/data/etc/spn-conf.xml
+
+%license LICENSE
+
+%files -n libtfeature
+%manifest feature/libtfeature.manifest
+%defattr(644,root,root,-)
+%{_libdir}/*.so
+
+%files -n libtfeature-devel
+%defattr(644,root,root,-)
+%{_libdir}/pkgconfig/*.pc
+%{_includedir}/tfeature/*.h