Sync from SPIN branch
[platform/core/telephony/tel-plugin-database.git] / packaging / tel-plugin-database.spec
index c96f9bf..94575bb 100644 (file)
@@ -1,46 +1,74 @@
-%define major 3
-%define minor 0
-%define patchlevel 1
-
-Name: tel-plugin-database
-Summary: Telephony DataBase storage plugin
-Version:    %{major}.%{minor}.%{patchlevel}
-Release:    1
-Group:      System/Libraries
-License:    Apache-2.0
-Source0:    tel-plugin-database-%{version}.tar.gz
-Source1001:    tel-plugin-database.manifest
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
+%define major 0
+%define minor 1
+%define patchlevel 21
+
+Name:           tel-plugin-database
+Version:        %{major}.%{minor}.%{patchlevel}
+Release:        1
+License:        Apache-2.0
+Summary:        Telephony DataBase storage plugin
+Group:          System/Libraries
+Source0:        tel-plugin-database-%{version}.tar.gz
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(db-util)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(tcore)
-BuildRequires:  pkgconfig(tel-headers)
-BuildRequires:  pkgconfig(db-util)
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
 
 %description
 Telephony DataBase storage plugin
 
 %prep
 %setup -q
-cp %{SOURCE1001} .
 
 %build
-%cmake .
-make %{?jobs:-j%jobs}
+versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DLIB_INSTALL_DIR=%{_libdir} \
+       -DVERSION=$versionint \
+%if 0%{?sec_product_feature_telephony_cdma}
+    -DOPERATOR_CDMA=1 \
+%endif
+
+make %{?_smp_mflags}
 
 %post
 /sbin/ldconfig
 
+mkdir -p /opt/dbspace
+
+rm -f /opt/dbspace/.mcc_mnc_oper_list.db
+sqlite3 /opt/dbspace/.mcc_mnc_oper_list.db < /tmp/mcc_mnc_oper_list.sql
+rm -f /tmp/mcc_mnc_oper_list.sql
+
+chmod 600 /opt/dbspace/.mcc_mnc_oper_list.db
+chown system:system /opt/dbspace/.mcc_mnc_oper_list.db
+chmod 644 /opt/dbspace/.mcc_mnc_oper_list.db-journal
+chown system:system /opt/dbspace/.mcc_mnc_oper_list.db-journal
+
+%if 0%{?sec_product_feature_telephony_cdma}
+       rm -f /opt/dbspace/.mcc_sid_list.db
+       sqlite3 /opt/dbspace/.mcc_sid_list.db < /tmp/mcc_sid_list.sql
+       rm -f /tmp/mcc_sid_list.sql
+       chmod 600 /opt/dbspace/.mcc_sid_list.db
+       chown system:system /opt/dbspace/.mcc_mnc_oper_list.db
+       chmod 644 /opt/dbspace/.mcc_sid_list.db-journal
+       chown system:system /opt/dbspace/.mcc_mnc_oper_list.db-journal
+%endif
+
 %postun -p /sbin/ldconfig
 
 %install
 %make_install
-mkdir -p %{buildroot}/usr/share/license
-cp LICENSE %{buildroot}/usr/share/license/%{name}
+mkdir -p %{buildroot}%{_datadir}/license
 
 %files
-%manifest %{name}.manifest
-%defattr(-,root,root,-)
+%defattr(644,system,system,-)
+/tmp/mcc_mnc_oper_list.sql
+%if 0%{?sec_product_feature_telephony_cdma}
+       /tmp/mcc_sid_list.sql
+%endif
+#%doc COPYING
 %{_libdir}/telephony/plugins/db-plugin*
-/usr/share/license/%{name}
+%{_datadir}/license/tel-plugin-database