Fix bugs in managing the system group
[platform/core/system/system-server.git] / packaging / system-server.spec
index 1b7aecd..09abfed 100755 (executable)
@@ -184,7 +184,7 @@ rm -f %{buildroot}%{_bindir}/restart
 
 %post
 #memory type vconf key init
-users_gid=$(getent group $TZ_SYS_USER_GROUP | cut -f3 -d':')
+users_gid=$(getent group %{TZ_SYS_USER_GROUP} | cut -f3 -d':')
 
 vconftool set -t int memory/sysman/usbhost_status -1 -i
 vconftool set -t int memory/sysman/mmc 0 -i
@@ -204,10 +204,10 @@ vconftool set -t int memory/sysman/mmc_unmount -1 -i
 vconftool set -t int memory/sysman/mmc_format -1 -i
 vconftool set -t int memory/sysman/mmc_format_progress 0 -i
 vconftool set -t int memory/sysman/mmc_err_status 0 -i
-vconftool set -t int memory/sysman/power_off 0 -g $users_gid -i -f
+vconftool set -t int memory/sysman/power_off 0 -g "$users_gid" -i -f
 vconftool set -t int memory/sysman/battery_level_status -1 -i
 vconftool set -t string memory/private/sysman/added_storage_uevent "" -i
-vconftool set -t string memory/private/sysman/removed_storage_uevent "" -g $users_gid -i
+vconftool set -t string memory/private/sysman/removed_storage_uevent "" -g "$users_gid" -i
 
 vconftool set -t int memory/sysman/hdmi 0 -i
 
@@ -216,13 +216,13 @@ vconftool set -t int memory/sysman/stime_changed 0 -i
 #db type vconf key init
 vconftool set -t int db/sysman/mmc_dev_changed 0 -i
 
-vconftool set -t int memory/pm/state 0 -i -g $users_gid
+vconftool set -t int memory/pm/state 0 -i -g "$users_gid"
 vconftool set -t int memory/pm/battery_timetofull -1 -i
 vconftool set -t int memory/pm/battery_timetoempty -1 -i
-vconftool set -t int memory/pm/sip_status 0 -i -g $users_gid
-vconftool set -t int memory/pm/custom_brightness_status 0 -i -g $users_gid
+vconftool set -t int memory/pm/sip_status 0 -i -g "$users_gid"
+vconftool set -t int memory/pm/custom_brightness_status 0 -i -g "$users_gid"
 vconftool set -t bool memory/pm/brt_changed_lpm 0 -i
-vconftool set -t int memory/pm/current_brt 60 -i -g $users_gid
+vconftool set -t int memory/pm/current_brt 60 -i -g "$users_gid"
 
 heynotitool set system_wakeup
 heynotitool set pm_event