Remove executable flag from non-executable files
[platform/core/system/system-popup.git] / packaging / system-servant.spec
old mode 100755 (executable)
new mode 100644 (file)
index a66c59d..dcf8a0f
@@ -1,5 +1,4 @@
 %bcond_with wayland
-%bcond_with emulator
 
 Name:       system-servant
 Summary:    Servant application for System FW
@@ -50,24 +49,25 @@ and service file for dbus activation
 %package profile_common
 Summary:       System-servant configured for common profile
 Provides:      system-servant-compat = %{version}-%{release}
+Conflicts:     system-servant-profile_mobile
+Conflicts:     system-servant-extension-rectangle-profile_wearable
+Conflicts:     system-servant-extension-circle-profile_wearable
+Conflicts:     system-servant-extension-profile_tv
 %description profile_common
 System-popup (system-servant) configured for common profile.
-The binary is shared between common/ivi/tv.
-
-%package profile_ivi
-Summary:       System-servant configured for common profile
-Provides:      system-servant-compat = %{version}-%{release}
-%description profile_ivi
-System-popup (system-servant) configured for IVI profile.
-The binary is shared between common/ivi/tv.
+The binary is shared between common/tv.
 
 %package profile_tv
 Summary:       System-servant configured for TV profile
 Provides:      system-servant-compat = %{version}-%{release}
 Requires:      org.tizen.crash-syspopup
+Conflicts:     system-servant-profile_mobile
+Conflicts:     system-servant-extension-rectangle-profile_wearable
+Conflicts:     system-servant-extension-circle-profile_wearable
+Conflicts:     system-servant-profile_common
 %description profile_tv
 System-popup (system-servant) configured for TV profile.
-The binary is shared between common/ivi/tv.
+The binary is shared between common/tv.
 
 %package profile_mobile
 Summary:       System-servant configured for mobile profile
@@ -77,11 +77,15 @@ Requires:   org.tizen.overheat-syspopup
 Requires:      org.tizen.system-signal-sender
 Requires:      org.tizen.powerkey-syspopup.mobile
 Requires:      org.tizen.system-syspopup.mobile
+Conflicts:     system-servant-extension-rectangle-profile_wearable
+Conflicts:     system-servant-extension-circle-profile_wearable
+Conflicts:     system-servant-profile_common
+Conflicts:     system-servant-extension-profile_tv
 %description profile_mobile
 System-popup (system-servant) configured for mobile profile.
 
 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 %package extension-circle-profile_wearable
 Summary:       System-servant configured for wearable profile
 Provides:      system-servant-compat = %{version}-%{release}
@@ -91,7 +95,10 @@ Requires:    org.tizen.powerkey-syspopup.wearable
 Requires:      org.tizen.system-syspopup.wearable
 Provides:      system-servant-profile_wearable
 Provides:      system-servant-compat
+Conflicts:     system-servant-profile_mobile
 Conflicts:     system-servant-extension-rectangle-profile_wearable
+Conflicts:     system-servant-profile_common
+Conflicts:     system-servant-extension-profile_tv
 %description extension-circle-profile_wearable
 System-popup (system-servant) configured for wearable profile.
 
@@ -104,7 +111,10 @@ Requires:  org.tizen.powerkey-syspopup.wearable
 Requires:      org.tizen.system-syspopup.wearable
 Provides:      system-servant-profile_wearable
 Provides:      system-servant-compat
+Conflicts:     system-servant-profile_mobile
 Conflicts:     system-servant-extension-circle-profile_wearable
+Conflicts:     system-servant-profile_common
+Conflicts:     system-servant-extension-profile_tv
 %description extension-rectangle-profile_wearable
 System-popup (system-servant) configured for wearable profile.
 %endif
@@ -249,7 +259,7 @@ ls -la profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
 ls -la profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
 
 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 # BUILD WEARABLE
 mkdir -p build_rec_wearable
 pushd build_rec_wearable
@@ -320,7 +330,7 @@ mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-p
 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png cir-profile_wearable/res/
 %endif
 
-# BUILD COMMON/TV/IVI
+# BUILD COMMON/TV
 mkdir -p build_common
 pushd build_common
 %cmake .. \
@@ -362,14 +372,14 @@ install -m 0644 profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/*.png %{
 %endif
 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
-install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
+install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
-install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
+install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
 
 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res
 install -m 0644 rec-profile_wearable/shared/res/*.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
@@ -378,10 +388,12 @@ install -m 0755 cir-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
 install -m 0755 rec-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
 install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
 install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
+install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
+install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
 install -m 0644 data/gear_device_options_bg.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
 install -m 0644 data/gear_device_options_power_off.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
-install -m 0644 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
-install -m 0644 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
+install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
+install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
 %endif
 
 #for common profile
@@ -398,17 +410,15 @@ rm %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
 # correct system-servant kept, you need to reinstall system-servant after
 # uninstalling profile_mobile
 mv /%{_bindir}/sysapp-launcher.mobile /%{_bindir}/sysapp-launcher
-mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
 
 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 %post extension-circle-profile_wearable
 # This does not support proper uninstall. To uninstall profile_wearable-circle with
 # correct system-servant kept, you need to reinstall system-servant after
 # uninstalling profile_wearable-circle
 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
-mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
 
 %post extension-rectangle-profile_wearable
@@ -416,7 +426,6 @@ mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{T
 # correct system-servant kept, you need to reinstall system-servant after
 # uninstalling profile_wearable-rectangle
 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
-mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
 %endif
 
@@ -426,9 +435,16 @@ mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{T
 # uninstalling profile_common
 mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 
+%post -n org.tizen.powerkey-syspopup.mobile
+mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
+
+%post -n org.tizen.powerkey-syspopup.wearable
+mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
+
 %files
 %manifest %{name}.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
+%{_unitdir}/system-popup.service
 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
 
@@ -496,7 +512,7 @@ mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
 
 %files profile_mobile
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{_bindir}/sysapp-launcher.mobile
 %{_bindir}/system-cooperator
@@ -509,54 +525,56 @@ mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 %{_datadir}/system-apps/res/icons/usb_icon.png
 
 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 %files extension-circle-profile_wearable
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{_bindir}/sysapp-launcher.wearable
 %{_bindir}/system-cooperator
 
 %files extension-rectangle-profile_wearable
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{_bindir}/sysapp-launcher.wearable
 %{_bindir}/system-cooperator
 %endif
 
 %files profile_common
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{_bindir}/sysapp-launcher.common
 
 %files -n org.tizen.crash-syspopup
 %manifest org.tizen.crash-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
 
 %files -n org.tizen.system-syspopup.mobile
 %manifest org.tizen.system-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj
 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
 
 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
-%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="ivi" && "%{?profile}"!="common"
+%if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
 %files -n org.tizen.system-syspopup.wearable
 %manifest org.tizen.system-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj
 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png
+%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_check.png
+%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_delete.png
 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
 
 %files -n org.tizen.powerkey-syspopup.wearable
 %manifest org.tizen.powerkey-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
@@ -568,7 +586,7 @@ mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 
 %files -n org.tizen.powerkey-syspopup.mobile
 %manifest org.tizen.powerkey-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
@@ -577,7 +595,7 @@ mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 
 %files -n org.tizen.overheat-syspopup
 %manifest org.tizen.overheat-syspopup.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/bin/overheat-popup
 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/shared/res/overheat-popup.edj
@@ -585,11 +603,10 @@ mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
 
 %files -n org.tizen.system-signal-sender
 %manifest org.tizen.system-signal-sender.manifest
-%license LICENSE
+%license LICENSE.Apache-2.0
 %defattr(-,root,root,-)
 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
 
 # The followings are meta packages to keep the compatibility with conventional profiles.
 %files profile_tv
-%files profile_ivi