Release version 0.3.1
[platform/core/base/syspopup.git] / packaging / syspopup.spec
index 9198ee9..527d453 100644 (file)
@@ -1,9 +1,6 @@
-%bcond_with x
-%bcond_with wayland
-
 Name:           syspopup
 Summary:        Syspopup package
-Version:        0.0.100
+Version:        0.3.1
 Release:        0
 Group:          System/Libraries
 License:        Apache-2.0
@@ -12,7 +9,6 @@ Source1001:     %{name}.manifest
 Source1002:     %{name}-devel.manifest
 Source1003:     %{name}-caller.manifest
 Source1004:     %{name}-caller-devel.manifest
-Source1005:    org.tizen.aul.syspopup.conf.in
 
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(sqlite3)
@@ -20,29 +16,19 @@ BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gio-2.0)
-%if %{with wayland}
-BuildRequires:  pkgconfig(ecore-wayland)
+BuildRequires:  pkgconfig(ecore-wl2)
 BuildRequires:  pkgconfig(capi-ui-efl-util)
-%else
-%if %{with x}
-BuildRequires:  pkgconfig(utilX)
-BuildRequires:  pkgconfig(x11)
-BuildRequires:  pkgconfig(ecore-x)
-%endif
-%endif
 BuildRequires:  pkgconfig(evas)
 BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(libtzplatform-config)
-BuildRequires:  pkgconfig(capi-appfw-application)
-BuildRequires:  pkgconfig(capi-system-system-settings)
-BuildRequires:  pkgconfig(libsystemd-daemon)
 BuildRequires:  pkgconfig(aul)
+BuildRequires:  pkgconfig(capi-system-info)
+BuildRequires:  pkgconfig(libsmack)
+BuildRequires:  pkgconfig(libxml-2.0)
+
+Requires(posttrans): /usr/bin/rm
 
-%if "%{?profile}" == "wearable"
-%define profile_wearable 1
-%else
-%define profile_wearable 0
-%endif
+%define upgrade_script_path /usr/share/upgrade/scripts
 
 %description
 syspopup package for popup
@@ -75,47 +61,28 @@ syspopup-caller development package for popup
 
 %prep
 %setup -q
-sed -i %{SOURCE1001} -e "s|TZ_SYS_DB|%TZ_SYS_DB|g"
 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} .
 
 %build
-%if %{?profile_wearable}
-PROFILE_WEARABLE=ON
-%endif
-
-%cmake \
-%if %{with wayland}
-       -Dwith_wayland=TRUE \
-%else
-%if %{with x}
-       -Dwith_x11=TRUE \
-%endif
-%endif
-       -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
+export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+%cmake -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
        -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
        -DEXTRA_CFLAGS=-fPIC \
-       -DPROFILE_WEARABLE:BOOL=${PROFILE_WEARABLE} \
+       -DFULLVER=%{version} \
+       -DMAJORVER=${MAJORVER} \
+       -DSYSCONFDIR=%{_sysconfdir} \
        .
 
 make %{?jobs:-j%jobs}
 
 %install
 %make_install
-mkdir -p %{buildroot}%{TZ_SYS_RO_SHARE}/license
-install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
-install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-devel
-install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-caller
-install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-caller-devel
-
-mkdir -p %{buildroot}%{TZ_SYS_DB}
-sqlite3 %{buildroot}%{TZ_SYS_DB}/.syspopup.db < %{buildroot}%{TZ_SYS_RO_SHARE}/syspopup/syspopup_db.sql
-rm -rf %{buildroot}%{TZ_SYS_RO_SHARE}/syspopup/syspopup_db.sql
-rm -rf %{buildroot}%{TZ_SYS_DB}/.syspopup.db-journal
-
+mkdir -p %{buildroot}%{_datadir}
 touch %{buildroot}%{_datadir}/popup_noti_term
 
-mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
-install -m 0644 %SOURCE1005 %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.tizen.aul.syspopup.conf
+mkdir -p %{buildroot}%{upgrade_script_path}
+cp -f scripts/502.syspopup_upgrade.sh %{buildroot}%{upgrade_script_path}
 
 %post -p /sbin/ldconfig
 
@@ -125,19 +92,63 @@ install -m 0644 %SOURCE1005 %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.tizen
 
 %postun caller -p /sbin/ldconfig
 
+%posttrans
+/usr/bin/sp_initdb
+
+if [ -e %{_sysconfdir}/config/model-config.xml ]; then
+       PROFILE=`grep "feature\/profile" %{_sysconfdir}/config/model-config.xml`
+       if [[ "${PROFILE}" == *"mobile"* ]]; then
+               rm -rf %{_datarootdir}/syspopup/wearable
+               rm -rf %{_datarootdir}/syspopup/tv
+               rm -rf %{_datarootdir}/syspopup/common
+               rm -rf %{_datarootdir}/syspopup/ivi
+       elif [[ "${PROFILE}" == *"wearable"* ]]; then
+               rm -rf %{_datarootdir}/syspopup/mobile
+               rm -rf %{_datarootdir}/syspopup/tv
+               rm -rf %{_datarootdir}/syspopup/common
+               rm -rf %{_datarootdir}/syspopup/ivi
+       elif [[ "${PROFILE}" == *"tv"* ]]; then
+               rm -rf %{_datarootdir}/syspopup/mobile
+               rm -rf %{_datarootdir}/syspopup/wearable
+               rm -rf %{_datarootdir}/syspopup/common
+               rm -rf %{_datarootdir}/syspopup/ivi
+       elif [[ "${PROFILE}" == *"common"* ]]; then
+               rm -rf %{_datarootdir}/syspopup/mobile
+               rm -rf %{_datarootdir}/syspopup/wearable
+               rm -rf %{_datarootdir}/syspopup/tv
+               rm -rf %{_datarootdir}/syspopup/ivi
+       elif [[ "${PROFILE}" == *"ivi"* ]]; then
+               rm -rf %{_datarootdir}/syspopup/mobile
+               rm -rf %{_datarootdir}/syspopup/wearable
+               rm -rf %{_datarootdir}/syspopup/tv
+               rm -rf %{_datarootdir}/syspopup/common
+       else
+               rm -rf %{_datarootdir}/syspopup/mobile
+               rm -rf %{_datarootdir}/syspopup/wearable
+               rm -rf %{_datarootdir}/syspopup/tv
+               rm -rf %{_datarootdir}/syspopup/common
+               rm -rf %{_datarootdir}/syspopup/ivi
+
+       fi
+else
+       rm -rf %{_datarootdir}/syspopup/mobile
+       rm -rf %{_datarootdir}/syspopup/wearable
+       rm -rf %{_datarootdir}/syspopup/tv
+       rm -rf %{_datarootdir}/syspopup/common
+       rm -rf %{_datarootdir}/syspopup/ivi
+fi
+
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
-%{_datadir}/icons/default/small/org.tizen.syspopup-app.png
 %{_bindir}/sp_test
-%{_bindir}/syspopup-app
-%{_libdir}/libsyspopup.so.0.1.0
-%TZ_SYS_RO_PACKAGES/org.tizen.syspopup-app.xml
+%{_bindir}/sp_initdb
+%{_libdir}/libsyspopup.so.*
 %{_datadir}/popup_noti_term
-
-%attr(644,root,%{TZ_SYS_USER_GROUP}) %{TZ_SYS_DB}/.syspopup.db
-
-%TZ_SYS_RO_SHARE/license/%{name}
+%license LICENSE
+%{upgrade_script_path}/502.syspopup_upgrade.sh
+%{_sysconfdir}/syspopup/preload/*
+%{_prefix}/share/syspopup/*
 
 %files devel
 %manifest %{name}-devel.manifest
@@ -146,14 +157,12 @@ install -m 0644 %SOURCE1005 %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.tizen
 %{_includedir}/syspopup.h
 %{_libdir}/libsyspopup.so
 %{_libdir}/pkgconfig/syspopup.pc
-%TZ_SYS_RO_SHARE/license/%{name}-devel
 
 %files caller
 %manifest %{name}-caller.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libsyspopup_caller.so.0.1.0
-%TZ_SYS_RO_SHARE/license/%{name}-caller
-%{_sysconfdir}/dbus-1/system.d/org.tizen.aul.syspopup.conf
+%{_libdir}/libsyspopup_caller.so.*
+%license LICENSE
 
 %files caller-devel
 %manifest %{name}-caller-devel.manifest
@@ -161,18 +170,3 @@ install -m 0644 %SOURCE1005 %{buildroot}%{_sysconfdir}/dbus-1/system.d/org.tizen
 %{_libdir}/libsyspopup_caller.so
 %{_includedir}/syspopup_caller.h
 %{_libdir}/pkgconfig/syspopup-caller.pc
-%TZ_SYS_RO_SHARE/license/%{name}-caller-devel
-
-
-%changelog
-* Tue Aug 13 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
-- Add key handler for esc of keyboard
-
-* Fri Jun 21 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
-- Change end key term info of wifi-qs
-
-* Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
-- Remove drm syspopup requested by hakjoo.ko
-
-* Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
-- Add syspopup_reset_timeout api