Remove hardcoded path for multiuser support
[platform/core/system/sync-agent.git] / packaging / sync-agent.spec
index 810becd..127934f 100755 (executable)
@@ -1,10 +1,14 @@
 Name:       sync-agent
 Summary:    Sync agent FW Library
-Version:    0.1.90
+Version:    0.1.91
 Release:    1
-Group:      TO_BE/FILLED_IN
-License:    Apache License, Version 2.0
+Group:      System/Service
+URL:        http://www.tizen.org
+License:    Apache-2.0
 Source0:    sync-agent-%{version}.tar.gz
+Source1001:    %{name}.manifest
+Source1002:    %{name}-devel.manifest
+Source1003:     common-public-plugins.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  pkgconfig(glib-2.0)
@@ -20,7 +24,6 @@ BuildRequires:  pkgconfig(pmapi)
 BuildRequires:  pkgconfig(accounts-svc)
 BuildRequires:  pkgconfig(contacts-service2)
 BuildRequires:  pkgconfig(memo)
-BuildRequires:  pkgconfig(push)
 BuildRequires:  pkgconfig(alarm-service)
 BuildRequires:  pkgconfig(location)
 BuildRequires:  pkgconfig(tapi)
@@ -39,13 +42,13 @@ BuildRequires:  pkgconfig(dlog)
 BuildRequires:  libgcrypt-devel
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dbus-glib-1)
-
+BuildRequires:  pkgconfig(libtzplatform-config)
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 
 
 %description
-sync-agent library (development headers)
+Tizen sync agent FW library
 
 
 %package devel
@@ -53,18 +56,11 @@ Summary:    Development files for %{name}
 Group:      Development/Libraries
 Requires:   %{name} = %{version}-%{release}
 %description devel
-Development files for %{name}
-
-#%package -n common-private-plugins
-#Summary:    Common Private Plugins
-#Group:      TO_BE_FILLED
-
-#%description -n common-private-plugins
-#common private plugins for sync-agent
+Provides required sync agent development headers and libraries for creating    sync enabled clients
 
 %package -n common-public-plugins
 Summary:    Common Public Plugins
-Group:      TO_BE_FILLED
+Group:      System/Service
 
 %description -n common-public-plugins
 common public plugins for sync-agent
@@ -72,10 +68,11 @@ common public plugins for sync-agent
 
 %prep
 %setup -q
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} .
 
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=/usr
+%cmake .
 
 
 make %{?jobs:-j%jobs}
@@ -90,12 +87,13 @@ rm -rf %{buildroot}
 
 
 %files
-%manifest sync-agent.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so
 %{_libdir}/*.so.*
 
 %files devel
+%manifest %{name}-devel.manifest
 %defattr(-,root,root,-)
 %{_includedir}/sync_agent.h
 %{_includedir}/sync-agent/*
@@ -109,5 +107,5 @@ rm -rf %{buildroot}
 %files -n common-public-plugins
 %manifest common-public-plugins.manifest
 %defattr(-,root,root,-)
-/usr/lib/sync-agent/common-public/*
+%{_libdir}/sync-agent/common-public/*