Change to operate in on-demand mode
[platform/core/connectivity/stc-manager.git] / packaging / stc-manager.spec
index b14ee3f..b86122b 100644 (file)
@@ -1,6 +1,6 @@
 Name:       stc-manager
 Summary:    STC(Smart Traffic Control) manager
-Version:    0.0.82
+Version:    0.0.91
 Release:    0
 Group:      Network & Connectivity/Other
 License:    Apache-2.0
@@ -70,6 +70,18 @@ Summary: Tethering plugin for data usage of tethering clients
 %description plugin-tether
 A smart traffic control manager extension for tethering client data usage plugin
 
+%package plugin-monitor
+Summary: Monitor plugin for data usage of clients
+
+%description plugin-monitor
+A smart traffic control manager extension for monitoring client data usage plugin
+
+%package plugin-firewall
+Summary: Firewall plugin for managing firewall rules
+
+%description plugin-firewall
+A smart traffic control manager extension for firewall plugin
+
 %prep
 %setup -q
 chmod 644 %{SOURCE0}
@@ -124,6 +136,9 @@ ln -s ../stc-manager.service %{buildroot}%{_libdir}/systemd/system/multi-user.ta
 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
 cp resources/dbus/stc-manager.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/stc-manager.conf
 
+mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services/
+cp resources/dbus/net.stc-manager.service %{buildroot}%{_datadir}/dbus-1/system-services/net.stc-manager.service
+
 %files
 %manifest %{name}.manifest
 %license LICENSE
@@ -138,6 +153,7 @@ cp resources/dbus/stc-manager.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/st
 
 #DBus DAC
 %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/*
+%attr(644,root,root) %{_datadir}/dbus-1/system-services/*
 
 %if %{?enable_database} == YES
 %config(noreplace) %attr(660, root, root) %{database_full_path}
@@ -168,3 +184,11 @@ cp resources/dbus/stc-manager.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/st
 %files plugin-tether
 %manifest %{name}.manifest
 %attr(500,root,root) %{_libdir}/stc-plugin-tether.so
+
+%files plugin-monitor
+%manifest %{name}.manifest
+%attr(500,root,root) %{_libdir}/stc-plugin-monitor.so
+
+%files plugin-firewall
+%manifest %{name}.manifest
+%attr(500,root,root) %{_libdir}/stc-plugin-firewall.so