Release of 1.4.0 / Added Version info
[platform/upstream/SSAT.git] / packaging / ssat.spec
index 3cb440a..aa2860a 100644 (file)
@@ -1,15 +1,21 @@
 Name:          ssat
 Summary:       Shell Script Automated Tester
-Version:       1.1.0
-Release:       1rc1
+Version:       1.4.0
+Release:       0
 Group:         Development/Tools
 Packager:      MyungJoo Ham <myungjoo.ham@samsung.com>
 License:       Apache-2.0
 Source0:       ssat-%{version}.tar.gz
 Source1001:    ssat.manifest
-BuildArch:     noarch
 
 Requires:      bash
+Requires:      perl
+
+## For the utility
+BuildRequires: meson
+BuildRequires: ninja
+BuildRequires: pkgconfig(libpng)
+BuildRequires: glib2-devel
 
 %description
 SSAT provides testing environment for shell scripts with Apache-2.0 license.
@@ -20,7 +26,9 @@ This is created to avoid any complications related with GPL licenses.
 cp %{SOURCE1001} .
 
 %build
-# DO NOTHING
+# Utilities
+meson --prefix=%{_prefix} --bindir=bin build util
+ninja -C build
 
 %install
 mkdir -p %{buildroot}%{_bindir}
@@ -29,9 +37,11 @@ install -p -m 0644 ssat-api.sh %{buildroot}%{_bindir}/
 pushd %{buildroot}%{_bindir}
 ln -s ssat.sh ssat
 popd
+DESTDIR=%{buildroot} ninja -C build install
 
 %files
 %manifest ssat.manifest
 %{_bindir}/ssat
 %{_bindir}/ssat.sh
 %{_bindir}/ssat-api.sh
+%{_bindir}/bmp2png