[Feature] use system-info api to get build info .
[apps/core/preloaded/settings.git] / packaging / settings.spec
index 9e1e5c5..3a11194 100755 (executable)
@@ -16,7 +16,6 @@ BuildRequires:  pkgconfig(devman_haptic)
 BuildRequires:  pkgconfig(bluetooth-api)
 BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(openssl)
-BuildRequires:  pkgconfig(iniparser)
 BuildRequires:  pkgconfig(heynoti)
 BuildRequires:  pkgconfig(ui-gadget-1)
 BuildRequires:  pkgconfig(json-glib-1.0)
@@ -123,17 +122,8 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
 
 #resetSound
-%ifarch %{arm}
-       DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/Over the horizon.mp3"
-%else
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
-%endif
-
-%ifarch %{arm}
-       DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/Whistle.mp3"
-%else
        DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
-%endif
 
        vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
        vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
@@ -200,7 +190,7 @@ GOPTION="-g 6514"
 %else
        vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
 %endif
-       #vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
+       vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
        vconftool $GOPTION set -t int db/setting/Brightness "-1"