Merge branch 'devel/tizen_3.0' into tizen
[platform/core/system/sensord.git] / packaging / sensord.spec
index 063d808..8af0b2d 100644 (file)
@@ -1,36 +1,28 @@
 Name:       sensord
 Summary:    Sensor daemon
-Version:    2.0.1
+Version:    2.0.6
 Release:    0
-Group:         System/Sensor Framework
+Group:      System/Sensor Framework
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
-Source1:       sensord.manifest
-Source2:       libsensord.manifest
+Source1:    sensord.service
+Source2:    sensord_command.socket
+Source3:    sensord_event.socket
 
 BuildRequires:  cmake
 BuildRequires:  libattr-devel
 BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(libsystemd-daemon)
-BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(cynara-creds-socket)
 BuildRequires:  pkgconfig(cynara-client)
 BuildRequires:  pkgconfig(cynara-session)
 Requires:   libsensord = %{version}-%{release}
 
-%define auto_rotation_state ON
-%define orientation_state OFF
-%define gravity_state OFF
-%define linear_accel_state OFF
-%define rv_state OFF
-%define geomagnetic_rv_state OFF
-%define gaming_rv_state OFF
-%define tilt_state OFF
-%define gyroscope_uncal_state OFF
-%define build_test_suite ON
+%ifarch %{ix86} x86_64
+%define BUILD_ARCH EMULATOR
+%endif
 
 %description
 Sensor daemon
@@ -58,7 +50,6 @@ Group:      System/Development
 %description -n sensor-hal-devel
 Sensord HAL interface
 
-%if %{build_test_suite} == "ON"
 %package -n sensor-test
 Summary:    Sensord library
 Group:      System/Testing
@@ -66,21 +57,12 @@ Group:      System/Testing
 %description -n sensor-test
 Sensor functional testing
 
-%endif
-
 %prep
 %setup -q
-cp %{SOURCE1} .
-cp %{SOURCE2} .
-
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DMAJORVER=${MAJORVER} -DFULLVER=%{version} \
-       -DORIENTATION=%{orientation_state} -DGRAVITY=%{gravity_state} \
-       -DLINEAR_ACCEL=%{linear_accel_state} -DRV=%{rv_state} \
-       -DGEOMAGNETIC_RV=%{geomagnetic_rv_state} -DGAMING_RV=%{gaming_rv_state} \
-       -DGYROSCOPE_UNCAL=%{gyroscope_uncal_state} -DAUTO_ROTATION=%{auto_rotation_state} \
-       -DTILT=%{tilt_state} -DTEST_SUITE=%{build_test_suite}
+       -DARCH=%{BUILD_ARCH}
 
 %build
 make %{?jobs:-j%jobs}
@@ -89,8 +71,15 @@ make %{?jobs:-j%jobs}
 rm -rf %{buildroot}
 %make_install
 
+mkdir -p %{buildroot}%{_unitdir}
+
+install -m 0644 %SOURCE1 %{buildroot}%{_unitdir}
+install -m 0644 %SOURCE2 %{buildroot}%{_unitdir}
+install -m 0644 %SOURCE3 %{buildroot}%{_unitdir}
+
 %install_service multi-user.target.wants sensord.service
-%install_service sockets.target.wants sensord.socket
+%install_service sockets.target.wants sensord_event.socket
+%install_service sockets.target.wants sensord_command.socket
 
 %post
 systemctl daemon-reload
@@ -98,23 +87,27 @@ systemctl daemon-reload
 %postun
 systemctl daemon-reload
 
-%post -n libsensord -p /sbin/ldconfig
+%post -n libsensord
+ln -sf %{_libdir}/libsensor.so.%{version} %{_libdir}/libsensor.so.1
+/sbin/ldconfig
 
-%postun -n libsensord -p /sbin/ldconfig
+%postun -n libsensord
+/sbin/ldconfig
 
 %files
-%attr(0644,root,root)/usr/etc/virtual_sensors.xml
-%manifest sensord.manifest
+%manifest packaging/sensord.manifest
 %{_bindir}/sensord
 %{_unitdir}/sensord.service
-%{_unitdir}/sensord.socket
+%{_unitdir}/sensord_command.socket
+%{_unitdir}/sensord_event.socket
 %{_unitdir}/multi-user.target.wants/sensord.service
-%{_unitdir}/sockets.target.wants/sensord.socket
+%{_unitdir}/sockets.target.wants/sensord_command.socket
+%{_unitdir}/sockets.target.wants/sensord_event.socket
 %license LICENSE.APLv2
 
 %files -n libsensord
 %defattr(-,root,root,-)
-%manifest libsensord.manifest
+%manifest packaging/libsensord.manifest
 %{_libdir}/libsensor.so.*
 %{_libdir}/libsensord-shared.so
 %license LICENSE.APLv2
@@ -129,9 +122,9 @@ systemctl daemon-reload
 %files -n sensor-hal-devel
 %defattr(-,root,root,-)
 %{_includedir}/sensor/sensor_hal.h
+%{_includedir}/sensor/sensor_hal_types.h
 %license LICENSE.APLv2
 
-%if %{build_test_suite} == "ON"
 %files -n sensor-test
 %defattr(-,root,root,-)
 %{_bindir}/api-test
@@ -140,4 +133,3 @@ systemctl daemon-reload
 %{_bindir}/multi-process-performance-test
 %{_bindir}/fusion-data-collection
 %license LICENSE.APLv2
-%endif