Cleanup internal package dependencies and so file path
[platform/core/system/sensord.git] / packaging / sensord.spec
index 81f613d..8ae48ac 100644 (file)
@@ -1,6 +1,6 @@
 Name:       sensord
 Summary:    Sensor daemon
-Version:    1.0.0
+Version:    2.0.0
 Release:    0
 Group:         System/Sensor Framework
 License:    Apache-2.0
@@ -19,42 +19,25 @@ BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(cynara-creds-socket)
 BuildRequires:  pkgconfig(cynara-client)
 BuildRequires:  pkgconfig(cynara-session)
-
-%define accel_state ON
-%define auto_rotation_state ON
-%define gyro_state ON
-%define proxi_state ON
-%define light_state ON
-%define geo_state ON
-%define pressure_state ON
-%define temperature_state ON
-%define ultraviolet_state ON
-%define orientation_state ON
-%define gravity_state ON
-%define linear_accel_state ON
-%define rv_state ON
-%define geomagnetic_rv_state ON
-%define gaming_rv_state ON
-%define tilt_state ON
-%define uncal_gyro_state ON
-%define bio_led_red_state ON
+Requires:   libsensord = %{version}-%{release}
+
+%define auto_rotation_state OFF
+%define orientation_state OFF
+%define gravity_state OFF
+%define linear_accel_state OFF
+%define rv_state OFF
+%define geomagnetic_rv_state OFF
+%define gaming_rv_state OFF
+%define tilt_state OFF
+%define gyroscope_uncal_state OFF
 %define build_test_suite ON
 
 %description
 Sensor daemon
 
-%package sensord
-Summary:    Sensor daemon
-Group:      System/Sensor Framework
-Requires:   %{name} = %{version}-%{release}
-
-%description sensord
-Sensor daemon
-
 %package -n libsensord
 Summary:    Sensord library
 Group:      System/Libraries
-Requires:   %{name} = %{version}-%{release}
 
 %description -n libsensord
 Sensord library
@@ -62,24 +45,15 @@ Sensord library
 %package -n libsensord-devel
 Summary:    Sensord shared library
 Group:      System/Development
-Requires:   %{name} = %{version}-%{release}
+Requires:   libsensord = %{version}-%{release}
 
 %description -n libsensord-devel
 Sensord shared library
 
-%package -n libsensord-plugins
-Summary:    Sensord plugin library
-Group:      System/Development
-Requires:   %{name} = %{version}-%{release}
-
-%description -n libsensord-plugins
-Sensord plugin library
-
 %if %{build_test_suite} == "ON"
 %package -n sensor-test
 Summary:    Sensord library
 Group:      System/Testing
-Requires:   %{name} = %{version}-%{release}
 
 %description -n sensor-test
 Sensor functional testing
@@ -91,15 +65,12 @@ Sensor functional testing
 cp %{SOURCE1} .
 cp %{SOURCE2} .
 
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DACCEL=%{accel_state} \
-       -DGYRO=%{gyro_state} -DPROXI=%{proxi_state} -DLIGHT=%{light_state} \
-       -DGEO=%{geo_state} -DPRESSURE=%{pressure_state} -DTEMPERATURE=%{temperature_state} \
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DORIENTATION=%{orientation_state} -DGRAVITY=%{gravity_state} \
        -DLINEAR_ACCEL=%{linear_accel_state} -DRV=%{rv_state} \
        -DGEOMAGNETIC_RV=%{geomagnetic_rv_state} -DGAMING_RV=%{gaming_rv_state} \
-       -DUNCAL_GYRO=%{uncal_gyro_state} -DAUTO_ROTATION=%{auto_rotation_state} \
-       -DTILT=%{tilt_state} -DULTRAVIOLET=%{ultraviolet_state} \
-       -DBIO_LED_RED=%{bio_led_red_state} -DTEST_SUITE=%{build_test_suite} \
+       -DGYROSCOPE_UNCAL=%{gyroscope_uncal_state} -DAUTO_ROTATION=%{auto_rotation_state} \
+       -DTILT=%{tilt_state} -DTEST_SUITE=%{build_test_suite} \
        -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir}
 
 %build
@@ -122,7 +93,7 @@ systemctl daemon-reload
 
 %postun -n libsensord -p /sbin/ldconfig
 
-%files -n sensord
+%files
 %attr(0644,root,root)/usr/etc/virtual_sensors.xml
 %manifest sensord.manifest
 %{_bindir}/sensord
@@ -147,11 +118,6 @@ systemctl daemon-reload
 %{_libdir}/pkgconfig/sensor.pc
 %license LICENSE.APLv2
 
-%files -n libsensord-plugins
-%defattr(-,root,root,-)
-%{_libdir}/libsensord-plugins.so
-%license LICENSE.APLv2
-
 %if %{build_test_suite} == "ON"
 %files -n sensor-test
 %defattr(-,root,root,-)