Merging tizen into ckm. Stage 3.
[platform/core/test/security-tests.git] / packaging / security-tests.spec
index 0978f8d..fac0fe8 100644 (file)
@@ -30,6 +30,7 @@ Requires(post): gum-utils
 Requires(postun): gum-utils
 Requires(postun): %{_bindir}/id
 Requires: perf
+Requires: gdb
 
 %description
 Security tests repository - for tests that can't be kept together with code.
@@ -45,6 +46,9 @@ cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
         -DDPL_LOG="ON"                    \
         -DVERSION=%{version}              \
         -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:DEBUG} \
+%if "%{sec_product_feature_security_mdfpp_enable}" == "1"
+        -DSECURITY_MDFPP_STATE_ENABLE=1 \
+%endif
         -DCMAKE_VERBOSE_MAKEFILE=ON       \
         -DCYNARA_DB_DIR=%{_localstatedir}/cynara/db \
         -DAPP_USER=security-tests-app
@@ -55,7 +59,7 @@ make %{?jobs:-j%jobs}
 ln -sf /etc/smack/test_smack_rules %{buildroot}/etc/smack/test_smack_rules_lnk
 
 %post
-%{_bindir}/gum-utils --add-user --username=security-tests-app --usertype=4 --offline
+%{_bindir}/gum-utils --add-user --username=security-tests-app --usertype=normal --offline
 
 find /etc/smack/test_privilege_control_DIR/ -type f -name exec -exec chmod 0755 {} +
 find /usr/apps/test_DIR/ -type f -name exec -exec chmod 0755 {} +
@@ -63,6 +67,12 @@ find /usr/apps/test_DIR/ -type f -name exec -exec chmod 0755 {} +
 # Load permissions templates
 api_feature_loader --verbose
 
+# Set vconf key for cc-mode testing if vconf key isn't there.
+%if "%{sec_product_feature_security_mdfpp_enable}" != "1"
+    echo "Install vconf key (file/security_mdpp/security_mdpp_state) for testing key-manager"
+    vconftool set -t string file/security_mdpp/security_mdpp_state "Unset"
+%endif
+
 echo "security-tests postinst done ..."
 
 %postun
@@ -73,7 +83,6 @@ echo "security-tests postinst done ..."
 %defattr(-, root, root, -)
 /usr/bin/security-tests.sh
 /usr/bin/security-tests-all.sh
-/usr/bin/tests-summary.sh
 /usr/bin/test-performance-check.sh
 
 /etc/dbus-1/system.d/security-tests.conf
@@ -105,4 +114,8 @@ echo "security-tests postinst done ..."
 /usr/bin/cynara-test
 /usr/bin/ckm-tests
 /usr/share/ckm-test/*
-
+/etc/security-tests
+/usr/lib/security-tests/cynara-tests/plugins/single-policy/*
+/usr/lib/security-tests/cynara-tests/plugins/multiple-policy/*
+/usr/lib/security-tests/cynara-tests/plugins/test-agent/*
+/usr/bin/security-tests-inner-test