Add macro %isu_package to generate ISU Package
[platform/upstream/rpm.git] / packaging / rpm.spec
index 5463a37..23fbb8f 100644 (file)
@@ -3,10 +3,10 @@
 
 Name:           rpm
 Summary:        The Package Manager
-License:        GPL-2.0+
+License:        LGPL-2.0+ and GPL-2.0+
 Group:          Base/Package Management
-Version:        4.11.0.1
-Release:        0
+Version:        4.14.1.1
+Release:        1
 Url:            http://www.rpm.org
 BuildRequires:  binutils
 BuildRequires:  bzip2
@@ -33,7 +33,11 @@ BuildRequires:  pkgconfig(nss)
 BuildRequires:  uthash-devel
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(libsmack)
+BuildRequires:  pkgconfig(libarchive)
 BuildRequires:  fdupes
+BuildRequires:  libdw-devel
+BuildRequires:  libelf-devel
+BuildRequires:  pkgconfig(libzstd)
 
 Provides:       rpminst
 Provides:       rpm-libs
@@ -43,6 +47,7 @@ Source2:        db-4.8.30-integration.dif
 Source4:        rpm-tizen_macros
 Source8:        rpmconfigcheck
 Source13:       find-docs.sh
+Source14:       find-isufiles.sh
 Source22:       device-sec-policy
 Source23:       find-provides.ksyms
 Source24:       debug.manifest
@@ -139,13 +144,13 @@ rm -f m4/libtool.m4
 rm -f m4/lt*.m4
 
 # Change hard-coded paths in man pages and .rc files
-[[ x"/usr/lib/rpm" != x%{rpmhome} ]] && \
+#[[ x"/usr/lib/rpm" != x%{rpmhome} ]] && \
    /bin/bash -c '/usr/bin/find %{_builddir} -type f -exec sed -e "s|/usr/lib/rpm|%{rpmhome}|g" -i {} \;'
 
 %build
 CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
 export CPPFLAGS
-export CFLAGS="%{optflags} -ffunction-sections -fPIE"
+export CFLAGS="%{optflags} -ffunction-sections -fstack-protector-strong -Wl,-z,relro -D_FORTIFY_SOURCE=2 -fPIE"
 export LDFLAGS="${LDFLAGS} -pie -Wl,-Bsymbolic-functions -ffunction-sections"
 %ifarch armv5tel
 export CFLAGS="-g -O0 -fno-strict-aliasing -ffunction-sections"
@@ -160,6 +165,7 @@ export CFLAGS="-g -O0 -fno-strict-aliasing -ffunction-sections"
     --enable-python \
     --with-vendor=tizen \
     --with-msm \
+    --enable-zstd \
     --with-rpmconfigdir=%{rpmhome}
 
 make %{?_smp_mflags}
@@ -174,6 +180,7 @@ mkdir -p %{buildroot}%{_sysconfdir}/rpm
 mkdir -p %{buildroot}%{rpmhome}/tizen
 cp -a tizen_macros %{buildroot}%{rpmhome}
 install -m 755 %{SOURCE13} %{buildroot}%{rpmhome}/tizen
+install -m 755 %{SOURCE14} %{buildroot}%{rpmhome}/tizen
 install -m 755 %{SOURCE23} %{buildroot}%{rpmhome}
 install -m 644 %{SOURCE9} %{buildroot}%{rpmhome}/fileattrs/libsymlink.attr
 install -m 644 %{SOURCE22} %{buildroot}%{_sysconfdir}/device-sec-policy
@@ -263,18 +270,22 @@ rm -f %{_dbpath}/Filemd5s \
 %{_bindir}/rpmquery
 %{_bindir}/rpmverify
 %{_bindir}/rpmqpack
+%{_bindir}/rpm2archive
 %attr(0755, root, root) %dir %{rpmhome}
 %{rpmhome}/macros
 %{rpmhome}/macros.d
 %{rpmhome}/rpmpopt*
 %{rpmhome}/rpmrc
+%attr(0755, root, root) %dir %{rpmhome}/tizen
 %{rpmhome}/tizen/macros
 %{rpmhome}/tizen_macros
 %{rpmhome}/rpm.supp
 %{rpmhome}/tgpg
 %{rpmhome}/platform
 %dir    %{__plugindir}
-%{__plugindir}/exec.so
+%{__plugindir}/ima.so
+%{__plugindir}/prioreset.so
+%{__plugindir}/syslog.so
 %{_libdir}/librpm.so.*
 %{_libdir}/librpmio.so.*
 %{_libdir}/librpmbuild.so.*
@@ -296,11 +307,14 @@ rm -f %{_dbpath}/Filemd5s \
 %{_bindir}/gendiff
 %{_bindir}/rpmspec
 %{_bindir}/rpmsign
+%attr(0755, root, root) %dir %{rpmhome}/tizen
 %{rpmhome}/tizen/find-*
 %{rpmhome}/brp-*
 %{rpmhome}/find-supplements*
 %{rpmhome}/check-*
 %{rpmhome}/debugedit
+%{rpmhome}/sepdebugcrcfix
+%{rpmhome}/python-macro-helper
 %{rpmhome}/find-debuginfo.sh
 %{rpmhome}/find-lang.sh
 %{rpmhome}/find-provides.ksyms