Release version 0.0.8
[platform/core/security/privilege-info.git] / packaging / privilege-info.spec
index faf710b..5764e4e 100644 (file)
@@ -1,6 +1,8 @@
+%{!?build_type:%global build_type RELEASE}
+
 Name:    privilege-info
 Summary: Privilege Information
-Version: 0.0.3
+Version: 0.0.8
 Release: 1
 Group:   Security/API
 License: Apache-2.0
@@ -8,17 +10,16 @@ Source0: %{name}-%{version}.tar.gz
 
 Requires(post):   /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
+
 BuildRequires: cmake
 BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(capi-base-common)
-BuildRequires: pkgconfig(security-privilege-manager)
-BuildRequires: pkgconfig(cynara-client)
-BuildRequires: pkgconfig(cynara-session)
-BuildRequires: pkgconfig(libsmack)
-BuildRequires: pkgconfig(libtzplatform-config)
 BuildRequires: pkgconfig(capi-system-info)
-Requires: tizen-locale
+BuildRequires: pkgconfig(security-privilege-manager)
+%if "%{build_type}" == "COVERAGE"
+BuildRequires: lcov
+%endif
 
 %description
 Provides Privilege Information(Privilege Info) API
@@ -29,71 +30,72 @@ Group:   Security/Development
 Requires: %{name} = %{version}-%{release}
 
 %description -n privilege-info-devel
-The Privilege Info API provides functions to get privilege information (DEV)
+The Privilege Info API provides functions to get privilege information (Development)
 
-%package -n tc-privilege-info
+%package -n privilege-info-tests
 Summary: Privilege Info TC
 Group:   Security/Testing
 Requires: %{name} = %{version}-%{release}
 
-%description -n tc-privilege-info
+%description -n privilege-info-tests
 Privilege Info API Internal Test
 
+%if "%{build_type}" == "COVERAGE"
+
+%package -n privilege-info-coverage
+Summary: Privilege Info code coverage data
+Group:   Security/Testing
+Requires: privilege-info-tests = %{version}-%{release}
+Requires: privilege-info-debugsource = %{version}-%{release}
+Requires: lcov
+Requires: gcc
+
+%description -n privilege-info-coverage
+Privilege Info code coverage data
+
+%endif
+
 %prep
 %setup -q
 
 %build
 
-export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
-export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
-
-echo cmake . -DPREFIX=%{_prefix} \
-        -DLIBDIR=%{_libdir} \
-        -DINCLUDEDIR=%{_includedir} \
-        -DCMAKE_BUILD_TYPE=%{build_type} \
-        -DVERSION=%{version} \
-        -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
-        -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
-
-cmake . -DPREFIX=%{_prefix} \
-        -DLIBDIR=%{_libdir} \
-        -DINCLUDEDIR=%{_includedir} \
-        -DCMAKE_BUILD_TYPE=%{build_type} \
-        -DVERSION=%{version} \
-        -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
-        -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
+%global coverage_dir %{_datadir}/privilege-info-coverage
+
+%cmake . -DCMAKE_BUILD_TYPE=%{build_type} -DCOVERAGE_DIR=%{coverage_dir}
 
 make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
-
 %make_install
 
+%clean
+rm -rf %{buildroot}
+
 %post -n privilege-info -p /sbin/ldconfig
 %postun -n privilege-info -p /sbin/ldconfig
 
-%post -n tc-privilege-info
-tpk-backend -y org.tizen.test-privilege-info --preload
-cyad -s -k MANIFESTS -c User::Pkg::org.tizen.test-privilege-info -u '*' -p http://tizen.org/privilege/contact.read -t DENY
-
 %files -n privilege-info
-%{_libdir}/libprivilege-info.so*
 %license LICENSE.Apache-2.0
 %manifest packaging/privilege-info.manifest
+%{_libdir}/libprivilege-info.so.*
 
 %files -n privilege-info-devel
+%manifest packaging/privilege-info.manifest
+%{_libdir}/libprivilege-info.so
 %{_includedir}/privilege_information.h
 %{_libdir}/pkgconfig/privilege-info.pc
 
-%files -n tc-privilege-info
-%manifest test/org.tizen.test-privilege-info.manifest
-%{TZ_SYS_RO_APP}/org.tizen.test-privilege-info/bin/tc-privilege-info-app-privacy
-%{TZ_SYS_RO_PACKAGES}/org.tizen.test-privilege-info.xml
-%{_bindir}/tc-privilege-info
+%files -n privilege-info-tests
+%manifest packaging/privilege-info.manifest
+%{_bindir}/privilege-info-tests
 
+%if "%{build_type}" == "COVERAGE"
 
-%clean
-rm -rf %{buildroot}
+%files -n privilege-info-coverage
+%manifest packaging/privilege-info.manifest
+%{_bindir}/privilege-info-coverage.sh
+%coverage_dir
 
+%endif