Clean up BuildRequires and remove unused DPL log code
[profile/ivi/phoned.git] / packaging / phoned.spec
index 6daf445..6ed3f77 100644 (file)
@@ -1,23 +1,17 @@
 Name:       phoned
-Summary:    A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime plugin
+Summary:    OFono/Obex business logic for phone web APIs
 Version:    0.0.0
 Release:    1
-Group:      Development/Libraries
+Group:      Automotive/Modello
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 
-BuildRequires:  pkgconfig(ewebkit2)
-BuildRequires:  pkgconfig(dpl-efl)
-BuildRequires:  pkgconfig(dpl-event-efl)
-BuildRequires:  pkgconfig(wrt-plugins-commons)
-BuildRequires:  pkgconfig(wrt-plugins-commons-javascript)
-
-BuildRequires:  evolution-data-server-devel
-BuildRequires:  wrt-plugins-tizen-devel
-BuildRequires:  expat-devel
 BuildRequires:  cmake
 BuildRequires:  gettext-devel
+BuildRequires:  pkgconfig(libebook-contacts-1.2)
+BuildRequires:  pkgconfig(expat)
 BuildRequires:  pkgconfig(json-glib-1.0)
+BuildRequires:  pkgconfig(dbus-1)
 
 %description
 A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime plugin
@@ -31,7 +25,7 @@ A service to export OFono/Obex functionality over DBUS, to be used by WebRuntime
 
 export LDFLAGS+="-Wl,--rpath=%{PREFIX} -Wl,--as-needed"
 
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DDPL_LOG="ON" -DENABLE_TIME_TRACER="OFF"
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DENABLE_TIME_TRACER="OFF"
 
 make %{?jobs:-j%jobs} VERBOSE=1
 
@@ -39,10 +33,6 @@ make %{?jobs:-j%jobs} VERBOSE=1
 rm -rf %{buildroot}
 %make_install
 
-%post
-
-%postun
-
 %files
 %{_libdir}/pkgconfig/phoned.pc
 %{_prefix}/sbin/phoned