Sync with tizen_2.2
[platform/framework/native/env-config.git] / packaging / osp-env-config.spec
old mode 100755 (executable)
new mode 100644 (file)
index 8148f29..007b62d
@@ -1,9 +1,9 @@
 Name:          osp-env-config
 Summary:       osp application environment cofiguration serivce
-Version:       1.2.1.0
+Version:       1.2.2.1
 Release:       2
 Group:         System/Libraries
-License:       Apache-2.0 or Flora
+License:       Apache-2.0
 Source0:       %{name}-%{version}.tar.gz
 Source1001:    osp-env-config.manifest
 BuildRequires:  cmake
@@ -11,20 +11,33 @@ BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(vconf)
 
 Requires(post): coreutils
+Requires(post): /sbin/ldconfig
 
 %description
 osp application environment cofiguration serivce
 
+%package devel
+Summary:       osp application environment cofiguration serivce (devel)
+Group:         System/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description devel
+osp application environment cofiguration serivce (devel)
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
 
-%build 
+%build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %ifarch %{ix86} x86_64
-CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_ -D_SECURE_LOG" %cmake .
+%if 0%{?simulator}
+CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_ -D_SECURE_LOG" %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+%else
+CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_  -D_SECURE_LOG" %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+%endif
 %else
-CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_ -D_SECURE_LOG" %cmake .
+CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_ -D_SECURE_LOG" %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 %endif
 
 # Call make instruction with smp support
@@ -46,4 +59,9 @@ cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license
 %manifest %{name}.manifest
 /usr/share/license/%{name}
 %{_libdir}/*.so*
+%{_libdir}/osp/libappinfo.so*
+/usr/etc/app-storage-exclude-dirs.list
 
+%files devel
+%{_includedir}/osp/*.h
+%{_libdir}/pkgconfig/appinfo.pc