Fix : Remove exception handling codes at the sample code
[platform/framework/native/content.git] / packaging / osp-content.spec
old mode 100644 (file)
new mode 100755 (executable)
index c84aa2d..6d6a7d1
@@ -1,6 +1,3 @@
-%define debug_package %{nil}
-%define __strip /bin/true
-
 Name:          osp-content
 Summary:       osp content library
 Version:       1.2.2.0
@@ -72,22 +69,18 @@ Requires:   %{name} = %{version}-%{release}
 %description internal-devel
 osp content library (Internal-DEV)
 
-%package debug
-Summary:    osp content library (Development)
-Group:      TO_BE/FILLED_IN
-Requires:   %{name} = %{version}-%{release}
-
-%description debug
-osp content library (DEV)
-
 %prep
 %setup -q
 
-%build 
+%build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %ifarch %{ix86}
+%if 0%{?simulator}
 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 %else
+CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
+%endif
+%else
 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 %endif
 
@@ -116,6 +109,3 @@ cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license
 
 %files internal-devel
 %{_includedir}/osp/content/*.h
-
-%files debug
-%{_libdir}/osp/debug/*.so*