Merge "sync code for tizen_2.2" into devel_3.0_main
[platform/framework/native/appfw.git] / packaging / osp-appfw.spec
index 1fb068d..6c470df 100644 (file)
@@ -1,6 +1,3 @@
-%define debug_package %{nil}
-%define __strip /bin/true
-
 Name:       osp-appfw
 Summary:    The App Framework library of OSP
 Version:    1.2.2.1
@@ -39,7 +36,6 @@ BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(dukgenerator)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(heynoti)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(eina)
 BuildRequires: pkgconfig(evas)
@@ -89,7 +85,7 @@ Requires: osp-env-config >= 1.2.2.1
 Requires: sqlite
 Requires: iniparser
 
-Provides:   libosp-appfw.so.1, libosp-newlib.so.1
+Provides:   libosp-appfw.so.1
 
 Requires(post): /sbin/ldconfig
 Requires(post): coreutils
@@ -116,22 +112,18 @@ Requires:   %{name} = %{version}-%{release}
 %description internal-devel
 The App Framework library of OSP (Internal-DEV)
 
-%package debug
-Summary:    The App Framework library of OSP (Development)
-Group:      TO_BE/FILLED_IN
-Requires:   %{name} = %{version}-%{release}
-
-%description debug
-The App Framework library of OSP (DEV)
-
 %prep
 %setup -q
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %ifarch %{ix86}
+%if 0%{?simulator}
 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
 %else
+CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
+%endif
+%else
 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
 %endif
 
@@ -183,7 +175,6 @@ chmod 444 /opt/usr/etc/clocale.list
 /usr/share/locale/*
 %config /usr/etc/*
 %{_libdir}/osp/libosp-appfw.so*
-%{_libdir}/osp/libosp-newlib.so*
 %{_libdir}/osp-server/libosp-appfw-server.so*
 %{_libdir}/osp-server/libosp-system-server.so*
 
@@ -205,8 +196,3 @@ chmod 444 /opt/usr/etc/clocale.list
 %{_libdir}/pkgconfig/osp-appfw-server.pc
 %{_libdir}/pkgconfig/osp-system-server.pc
 
-%files debug
-%{_libdir}/osp/debug/libosp-appfw.so*
-%{_libdir}/osp/debug/libosp-newlib.so*
-%{_libdir}/osp-server/debug/libosp-appfw-server.so*
-%{_libdir}/osp-server/debug/libosp-system-server.so*