move redundant logic to server
[platform/framework/native/appfw.git] / packaging / osp-appfw.spec
index e515683..19d49b5 100644 (file)
@@ -36,7 +36,6 @@ BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(dukgenerator)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(heynoti)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(eina)
 BuildRequires: pkgconfig(evas)
@@ -86,7 +85,7 @@ Requires: osp-env-config >= 1.2.2.1
 Requires: sqlite
 Requires: iniparser
 
-Provides:   libosp-appfw.so.1, libosp-newlib.so.1
+Provides:   libosp-appfw.so.1
 
 Requires(post): /sbin/ldconfig
 Requires(post): coreutils
@@ -109,6 +108,7 @@ The  App Framework library of OSP (DEV)
 Summary:    osp app framework internel (Internal)
 Group:      TO_BE/FILLED_IN
 Requires:   %{name} = %{version}-%{release}
+Requires:   %{name}-devel
 
 %description internal-devel
 The App Framework library of OSP (Internal-DEV)
@@ -118,12 +118,24 @@ The App Framework library of OSP (Internal-DEV)
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+
 %ifarch %{ix86}
-CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
+       ARCH=x86
+       CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_"
+       %if 0%{?simulator}
+               CXXFLAGS="$CXXFLAGS -D_OSP_EMUL_"
+       %endif
 %else
-CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
+       ARCH=arm
+       CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_"
+%endif
+
+%if 0%{?tizen_build_binary_release_type_eng}
+       CXXFLAGS="$CXXFLAGS -D_SECURE_LOG"
 %endif
 
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=${ARCH}
+
 # Call make instruction with smp support
 #make %{?jobs:-j%jobs}
 make %{?_smp_mflags}
@@ -134,7 +146,7 @@ rm -rf %{buildroot}
 %install
 mkdir -p %{buildroot}/usr/share/license
 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
-cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
+cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2 >> %{buildroot}/usr/share/license/%{name}
 
 %make_install
 
@@ -172,14 +184,12 @@ chmod 444 /opt/usr/etc/clocale.list
 /usr/share/locale/*
 %config /usr/etc/*
 %{_libdir}/osp/libosp-appfw.so*
-%{_libdir}/osp/libosp-newlib.so*
 %{_libdir}/osp-server/libosp-appfw-server.so*
 %{_libdir}/osp-server/libosp-system-server.so*
 
 %files devel
 %{_includedir}/osp/*.h
 %{_includedir}/osp/*.hpp
-%{_libdir}/pkgconfig/osp-appfw.pc
 
 %files internal-devel
 %{_includedir}/osp/app/*
@@ -191,6 +201,7 @@ chmod 444 /opt/usr/etc/clocale.list
 %{_includedir}/osp/text/*
 %{_includedir}/osp/server/*
 %{_includedir}/osp/system-server/*
+%{_libdir}/pkgconfig/osp-appfw.pc
 %{_libdir}/pkgconfig/osp-appfw-server.pc
 %{_libdir}/pkgconfig/osp-system-server.pc