add vconf keys for the mock functions
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index ee72814..fd813bd 100755 (executable)
@@ -63,8 +63,12 @@ BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
 BuildRequires:  pkgconfig(capi-network-tethering)
 BuildRequires:  pkgconfig(capi-network-nfc)
+BuildRequires:  pkgconfig(capi-security-privacy-manager)
+BuildRequires:  pkgconfig(privacy-manager-client)
+BuildRequires:  pkgconfig(privacy-manager-server)
 BuildRequires:  pkgconfig(ecore-evas)
 BuildRequires:  pkgconfig(pkgmgr)
+BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
@@ -122,7 +126,7 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int db/setting/select_network_act "0"
        vconftool $GOPTION set -t int db/setting/network_mode "0"
        vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
-       vconftool $GOPTION set -t bool db/setting/data_roaming "1"
+       vconftool $GOPTION set -t bool db/setting/data_roaming "0"
 
 #resetUsbConnectivity
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
@@ -161,37 +165,6 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
        vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
 
-#resetTilt
-       vconftool $GOPTION set -t bool db/setting/use_tilt "1"
-       vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
-       vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
-       vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
-
-#resetPanning
-       vconftool $GOPTION set -t bool db/setting/use_panning "0"
-       vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
-       vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
-       vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
-
-#resetDoubleTap
-       vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
-
-#resetShake
-       vconftool $GOPTION set -t bool db/setting/use_shake "1"
-
-#resetPickup
-       vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
-       vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
-
-#resetTurnOver
-       vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
-
-#resetMotions
-       vconftool $GOPTION set -t bool db/setting/motion_active "1"
-       vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
-       vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
-       vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
-
 #resetDisplay
        #backlight
 # Set backlight timeout to dim display on all platforms except emulator
@@ -214,38 +187,15 @@ GOPTION="-g 6514"
        #launch
        #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
 
-       #smart screen
-       vconftool $GOPTION set -t int db/pm/smartstay_status "0"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
-       vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
-
 #resetPowersaving
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
-
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
-
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
 
        #v0.4
         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
         vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
 
 #resetFont
-       vconftool $GOPTION set -t int db/setting/font_size "1"
        vconftool $GOPTION set -t int db/setting/font_type "0"
 
 #resetRotationLock
@@ -261,6 +211,12 @@ GOPTION="-g 6514"
 
        vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
        vconftool $GOPTION set -t int db/setting/date_format "0"
+
+       #-----------------------------------------------------------------
+       # MOCK FUNCTION
+       # MOCK IMPLEMENTATION FOR API COMPATIBILITY
+       # NEED TO CHECK THE KEY WITH THE CALENDAR APP
+       #-----------------------------------------------------------------
        vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
 
        vconftool $GOPTION set -t string db/setting/timezone "+9"
@@ -277,42 +233,20 @@ GOPTION="-g 6514"
 
 
 #resetAccessibility
-       vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
-       vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
-       vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
        vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
        #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
        vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
+
+       #-----------------------------------------------------------------
+       # MOCK FUNCTION
+       # NOT SUPPORTED BUT ADDED FOR API COMPATIBILITY
+       # temp key for screen reader & speech rate
+       #-----------------------------------------------------------------
        vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
        vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
-       vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
-       vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
-       vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
-       vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
-
-       vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
-       vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
-       vconftool $GOPTION set -t int db/ciss/answering_mode "0"
-       vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
-
-       vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
-        vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
-        vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
-        vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
-
-#Driving Mode
-       vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
-
 #resetLanguageAndRegion
-       vconftool $GOPTION set -t int db/setting/lang "9"
+       vconftool $GOPTION set -t int db/setting/lang "10"
        vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
        vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
 
@@ -329,57 +263,18 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
        vconftool $GOPTION set -t int db/setting/roaming_network "0"
 
-#resetNotification
-       vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
-
-        # display content
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
-
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
-
 #resetSecurity
        rm -rf /opt/data/setting/set_info
        #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
-
-       vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
-       vconftool $GOPTION set -t bool db/setting/simple_password "1"
-       vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
-       vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
-       vconftool $GOPTION set -t string db/setting/fmm/recipients ""
-       vconftool $GOPTION set -t string db/setting/fmm/sender ""
-       vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
-       vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
-       vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
-
+       vconftool $GOPTION set -t int db/setting/screen_lock_type "5" -f
+       vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen"
        # NOT USED NOW.
        #vconftool $GOPTION set -t bool db/setting/rcs "0"
 
-       vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
-       vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
-       vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
-       vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
-       vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
 #resetMemory
-       vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
        vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
        vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
        vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
-       vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
-       vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
-       vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
-       vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
 
        # format - system server
        #vconftool $GOPTION -i set -t int memory/mmc/format "0"
@@ -394,12 +289,6 @@ GOPTION="-g 6514"
 #resetDevoptions
        vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
 
-#resetDatausage
-       vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
-       vconftool $GOPTION set -t int db/setting/data_limit "0"
-       vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
-       vconftool $GOPTION set -t int db/setting/data_each_month "1"
-
 #resetDisplay
        vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
 
@@ -422,6 +311,7 @@ mkdir -p /usr/ug/bin/
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-privacy-efl
 
 %files -n org.tizen.setting
 %manifest settings.manifest