Fixing backlight issue. IA is currently getting a timeout of 10min, when it should...
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index 0f3e451..fabf4c1 100755 (executable)
@@ -3,7 +3,7 @@ Summary:    Setting application
 Version:    0.1.87
 Release:    99
 Group:      misc
-License:    samsung
+License:    Flora License, Version 1
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig(appcore-common)
 BuildRequires:  pkgconfig(appcore-efl)
@@ -62,6 +62,7 @@ BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(capi-network-tethering)
 BuildRequires:  pkgconfig(capi-network-nfc)
 BuildRequires:  pkgconfig(ecore-evas)
 BuildRequires:  pkgconfig(pkgmgr)
@@ -69,6 +70,8 @@ BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
 BuildRequires:  gettext-tools
+#Requires: org.tizen.phone
+Requires: ug-bluetooth-efl
 %description
 Setting application
  BEAT UI, Setting application.
@@ -192,11 +195,13 @@ GOPTION="-g 6514"
 
 #resetDisplay
        #backlight
-%ifarch %{arm}
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
-%else
+# Set backlight timeout to dim display on all platforms except emulator
+%if 0%{?simulator}
        vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
+%else
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
 %endif
+
        vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
@@ -244,6 +249,7 @@ GOPTION="-g 6514"
 
 #resetRotationLock
        vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
+       vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
        #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
 #resetTimeAndData
 %ifarch %{arm}
@@ -412,6 +418,7 @@ sync
 
 mkdir -p /usr/ug/bin/
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
 
 %files -n org.tizen.setting
 %manifest settings.manifest