fix app launching fail
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index 30f7393..c7e2b27 100755 (executable)
@@ -53,6 +53,7 @@ BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(capi-system-runtime-info)
 BuildRequires:  pkgconfig(capi-media-player)
 BuildRequires:  pkgconfig(capi-media-sound-manager)
+BuildRequires:  pkgconfig(capi-content-media-content)
 BuildRequires:  pkgconfig(capi-system-device)
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(capi-appfw-app-manager)
@@ -61,6 +62,7 @@ BuildRequires:  pkgconfig(capi-system-haptic)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(pkgmgr)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
@@ -128,7 +130,7 @@ GOPTION="-g 6514"
        DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
 
        vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
-       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
+       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
 
        vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
        vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
@@ -147,7 +149,7 @@ GOPTION="-g 6514"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
-
+       vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
        vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
 
 #resetWallpaper
@@ -422,7 +424,7 @@ ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
 
 /opt/share/packages/org.tizen.setting.xml
 /opt/share/packages/ug-setting-accessibility-efl.xml
-/opt/share/packages/ug-setting-font-efl.xml
+#/opt/share/packages/ug-setting-font-efl.xml
 
 /opt/share/icons/default/small/org.tizen.setting.png
 /opt/share/settings/*