Merge branch 'tizen_2.1'
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index 9da77ad..6634e43 100755 (executable)
@@ -1,9 +1,9 @@
-Name:       settings
+Name:       org.tizen.setting
 Summary:    Setting application
 Version:    0.1.87
 Release:    99
 Group:      misc
-License:    samsung
+License:    Flora License, Version 1
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig(appcore-common)
 BuildRequires:  pkgconfig(appcore-efl)
@@ -12,11 +12,10 @@ BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(tapi)
 BuildRequires:  pkgconfig(utilX)
 BuildRequires:  pkgconfig(devman)
-BuildRequires:  pkgconfig(devman_haptic)
+BuildRequires:  pkgconfig(haptic)
 BuildRequires:  pkgconfig(bluetooth-api)
 BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(openssl)
-BuildRequires:  pkgconfig(heynoti)
 BuildRequires:  pkgconfig(ui-gadget-1)
 BuildRequires:  pkgconfig(json-glib-1.0)
 BuildRequires:  pkgconfig(libxml-2.0)
@@ -43,28 +42,36 @@ BuildRequires:  pkgconfig(ewebkit2)
 BuildRequires:  pkgconfig(evas)
 BuildRequires:  pkgconfig(edje)
 BuildRequires:  pkgconfig(mm-player)
-BuildRequires:  pkgconfig(network)
-BuildRequires:  pkgconfig(security-server)
+BuildRequires:  pkgconfig(capi-network-connection)
+#BuildRequires:  pkgconfig(network)
+#BuildRequires:  pkgconfig(security-server)
 BuildRequires:  pkgconfig(svi)
 BuildRequires:  pkgconfig(appsvc)
-BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(notification)
 BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(capi-system-runtime-info)
 BuildRequires:  pkgconfig(capi-media-player)
 BuildRequires:  pkgconfig(capi-media-sound-manager)
+BuildRequires:  pkgconfig(capi-content-media-content)
 BuildRequires:  pkgconfig(capi-system-device)
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-sensor)
-BuildRequires:  pkgconfig(capi-system-haptic)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
+BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(capi-network-tethering)
+BuildRequires:  pkgconfig(capi-network-nfc)
+BuildRequires:  pkgconfig(ecore-evas)
+BuildRequires:  pkgconfig(pkgmgr)
+BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
 BuildRequires:  gettext-tools
+#Requires: org.tizen.phone
+Requires: ug-bluetooth-efl
 %description
 Setting application
  BEAT UI, Setting application.
@@ -75,9 +82,9 @@ Setting application
 
 %build
 
-%define PREFIX    "/opt/apps/org.tizen.setting"
-%define RESDIR    "/opt/apps/org.tizen.setting/res"
-%define DATADIR    "/opt/apps/org.tizen.setting/data"
+%define PREFIX    "/usr/apps/org.tizen.setting"
+%define RESDIR    "/usr/apps/org.tizen.setting/res"
+%define DATADIR    "/usr/apps/org.tizen.setting/data"
 CFLAGS+=" -fPIC";export CFLAGS
 CXXFLAGS+=" -fPIC";export CFLAGS
 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
@@ -109,7 +116,7 @@ GOPTION="-g 6514"
 
 
 #resetFlightmode
-       vconftool $GOPTION set -t bool db/setting/flight_mode "0"
+       vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
 
 #resetNetwork
        vconftool $GOPTION set -t int db/setting/select_network "0"
@@ -122,13 +129,14 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
+       vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
        DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
 
        vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
-       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
+       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
 
        vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
        vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
@@ -147,7 +155,7 @@ GOPTION="-g 6514"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/noti/email_alert_rep_type                "0"
-
+       vconftool $GOPTION set -t bool db/setting/sound/touch_sounds "1"
        vconftool $GOPTION set -t bool db/setting/sound/sound_lock "1"
 
 #resetWallpaper
@@ -187,11 +195,15 @@ GOPTION="-g 6514"
 
 #resetDisplay
        #backlight
-%ifarch %{arm}
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
+# Set backlight timeout to dim display on all platforms except emulator
+# 0 sec : unlimited time
+# 600 sec : 10 min
+%if 0%{?simulator}
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
 %else
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
 %endif
+
        vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
@@ -239,7 +251,8 @@ GOPTION="-g 6514"
 
 #resetRotationLock
        vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
-
+       vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
+       #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
 #resetTimeAndData
 %ifarch %{arm}
        vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
@@ -272,6 +285,7 @@ GOPTION="-g 6514"
        #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
        vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
        vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
+       vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
        vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
        vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
@@ -299,9 +313,9 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
 
 #resetLanguageAndRegion
-       vconftool $GOPTION set -t int db/setting/lang "2"
-       vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
-       vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
+       vconftool $GOPTION set -t int db/setting/lang "9"
+       vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
+       vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
 
 #resetViewtype
        #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
@@ -382,11 +396,10 @@ GOPTION="-g 6514"
        vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
 
 #resetDatausage
-       vconftool $GOPTION set -t bool db/setting/mobile_data "1"
-       vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
-       vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
-       vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
-       vconftool $GOPTION set -t int db/setting/data_each_month "10"
+       vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
+       vconftool $GOPTION set -t int db/setting/data_limit "0"
+       vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
+       vconftool $GOPTION set -t int db/setting/data_each_month "1"
 
 #resetDisplay
        vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
@@ -401,36 +414,34 @@ fi
 # create setting.cfg at runtime right after installation
 #/opt/apps/org.tizen.setting/bin/setting_conf_util
 # After flashing, initialize timezone file
-/opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
+/usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
 chown 5000:5000 /opt/data/setting -R
 #------------------------------------------
-heynotitool set setting_time_changed -a
 sync
 
-mkdir -p /opt/ug/bin/
-ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
-# ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
+mkdir -p /usr/ug/bin/
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
 
-%files -n settings
-#%manifest settings.manifest
+%files -n org.tizen.setting
+%manifest settings.manifest
 %defattr(-,root,root,-)
 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
 %attr(-,app,app) %dir /opt/data/setting
-/opt/apps/org.tizen.setting/bin/setting
-/opt/apps/org.tizen.setting/bin/setting_conf_util
+/usr/apps/org.tizen.setting/bin/setting
+/usr/apps/org.tizen.setting/bin/setting_conf_util
 /opt/data/setting/setting.cfg
 
-/opt/share/packages/org.tizen.setting.xml
-/opt/share/packages/ug-setting-accessibility-efl.xml
-/opt/share/packages/ug-setting-font-efl.xml
+/usr/share/packages/org.tizen.setting.xml
 
-/opt/share/icons/default/small/org.tizen.setting.png
+/usr/share/icons/default/small/org.tizen.setting.png
 /opt/share/settings/*
-/opt/apps/org.tizen.setting/res/*
-/opt/apps/org.tizen.setting/lib/*
-/opt/apps/org.tizen.setting/data/*
-/opt/ug/lib/*
+/usr/apps/org.tizen.setting/res/*
+/usr/apps/org.tizen.setting/lib/*
+/usr/apps/org.tizen.setting/data/*
+/usr/ug/lib/*
 /opt/data/setting/langlist.xml
 /opt/data/setting/plugin-cfg/*
 /opt/data/setting/plugin-xml/*
-/opt/apps/org.tizen.setting/bin/test_server
+#/usr/apps/org.tizen.setting/bin/test_server