Merge branch 'tizen_2.1'
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index 8eb6c1c..6634e43 100755 (executable)
@@ -3,7 +3,7 @@ Summary:    Setting application
 Version:    0.1.87
 Release:    99
 Group:      misc
-License:    samsung
+License:    Flora License, Version 1
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig(appcore-common)
 BuildRequires:  pkgconfig(appcore-efl)
@@ -47,7 +47,6 @@ BuildRequires:  pkgconfig(capi-network-connection)
 #BuildRequires:  pkgconfig(security-server)
 BuildRequires:  pkgconfig(svi)
 BuildRequires:  pkgconfig(appsvc)
-BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(notification)
 BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(capi-system-runtime-info)
@@ -62,14 +61,17 @@ BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(capi-network-tethering)
 BuildRequires:  pkgconfig(capi-network-nfc)
 BuildRequires:  pkgconfig(ecore-evas)
 BuildRequires:  pkgconfig(pkgmgr)
+BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
 BuildRequires:  gettext-tools
-Requires: org.tizen.phone
+#Requires: org.tizen.phone
+Requires: ug-bluetooth-efl
 %description
 Setting application
  BEAT UI, Setting application.
@@ -127,7 +129,7 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
-       vconftool $GOPTION set -t bool db/setting/debug_mode "0" -f
+       vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
@@ -193,11 +195,15 @@ GOPTION="-g 6514"
 
 #resetDisplay
        #backlight
-%ifarch %{arm}
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
+# Set backlight timeout to dim display on all platforms except emulator
+# 0 sec : unlimited time
+# 600 sec : 10 min
+%if 0%{?simulator}
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
 %else
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
 %endif
+
        vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
@@ -245,6 +251,7 @@ GOPTION="-g 6514"
 
 #resetRotationLock
        vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
+       vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
        #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
 #resetTimeAndData
 %ifarch %{arm}
@@ -278,6 +285,7 @@ GOPTION="-g 6514"
        #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
        vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
        vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
+       vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
        vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
        vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
@@ -413,6 +421,8 @@ sync
 
 mkdir -p /usr/ug/bin/
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
 
 %files -n org.tizen.setting
 %manifest settings.manifest