support default tone for call and noti
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index fd813bd..547281f 100755 (executable)
@@ -133,6 +133,7 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
        vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
+       vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
@@ -151,9 +152,11 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
 
        vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
+       vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
+       vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
@@ -165,6 +168,9 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
        vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
 
+#resetMotions
+       vconftool $GOPTION set -t bool db/setting/motion_active "1"
+
 #resetDisplay
        #backlight
 # Set backlight timeout to dim display on all platforms except emulator
@@ -191,11 +197,8 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
 
-       #v0.4
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
-
 #resetFont
+       vconftool $GOPTION set -t int db/setting/font_size "1"
        vconftool $GOPTION set -t int db/setting/font_type "0"
 
 #resetRotationLock
@@ -211,6 +214,7 @@ GOPTION="-g 6514"
 
        vconftool $GOPTION set -t int db/menu_widget/regionformat_time1224 "1"
        vconftool $GOPTION set -t int db/setting/date_format "0"
+       vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
 
        #-----------------------------------------------------------------
        # MOCK FUNCTION
@@ -233,9 +237,14 @@ GOPTION="-g 6514"
 
 
 #resetAccessibility
+       vconftool $GOPTION set -t bool db/setting/accessibility/accessibility "0"
+       vconftool $GOPTION set -t bool db/setting/accessibility/high_contrast "0"
+       vconftool $GOPTION set -t bool db/setting/accessibility/screen_zoom "1"
        vconftool $GOPTION set -t int db/setting/accessibility/font_size "1"
        #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
        vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
+       vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
+       vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
        #-----------------------------------------------------------------
        # MOCK FUNCTION
@@ -268,13 +277,19 @@ GOPTION="-g 6514"
        #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
        vconftool $GOPTION set -t int db/setting/screen_lock_type "5" -f
        vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen"
+
        # NOT USED NOW.
        #vconftool $GOPTION set -t bool db/setting/rcs "0"
 
 #resetMemory
+       vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
        vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
        vconftool $GOPTION set -t int db/setting/default_memory/camera "0"
        vconftool $GOPTION set -t int db/setting/default_memory/voice_recorder "0"
+       vconftool $GOPTION set -t int db/setting/default_memory/fm_radio "0"
+       vconftool $GOPTION set -t int db/setting/default_memory/all_share "0"
+       vconftool $GOPTION set -t int db/setting/default_memory/adobe_air "0"
+       vconftool $GOPTION set -t int db/setting/default_memory/dvb_h "0"
 
        # format - system server
        #vconftool $GOPTION -i set -t int memory/mmc/format "0"