support default tone for call and noti
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index 4d48d7e..547281f 100755 (executable)
@@ -3,7 +3,7 @@ Summary:    Setting application
 Version:    0.1.87
 Release:    99
 Group:      misc
-License:    samsung
+License:    Flora License, Version 1
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig(appcore-common)
 BuildRequires:  pkgconfig(appcore-efl)
@@ -47,7 +47,6 @@ BuildRequires:  pkgconfig(capi-network-connection)
 #BuildRequires:  pkgconfig(security-server)
 BuildRequires:  pkgconfig(svi)
 BuildRequires:  pkgconfig(appsvc)
-BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(notification)
 BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(capi-system-runtime-info)
@@ -62,14 +61,20 @@ BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(capi-network-tethering)
 BuildRequires:  pkgconfig(capi-network-nfc)
+BuildRequires:  pkgconfig(capi-security-privacy-manager)
+BuildRequires:  pkgconfig(privacy-manager-client)
+BuildRequires:  pkgconfig(privacy-manager-server)
 BuildRequires:  pkgconfig(ecore-evas)
 BuildRequires:  pkgconfig(pkgmgr)
+BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
 BuildRequires:  gettext-tools
-Requires: org.tizen.phone
+#Requires: org.tizen.phone
+Requires: ug-bluetooth-efl
 %description
 Setting application
  BEAT UI, Setting application.
@@ -121,13 +126,14 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int db/setting/select_network_act "0"
        vconftool $GOPTION set -t int db/setting/network_mode "0"
        vconftool $GOPTION set -t bool db/setting/3gEnabled "1"
-       vconftool $GOPTION set -t bool db/setting/data_roaming "1"
+       vconftool $GOPTION set -t bool db/setting/data_roaming "0"
 
 #resetUsbConnectivity
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
        vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
+       vconftool $GOPTION set -t int db/setting/default_rendering_engine "1" -i
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
@@ -146,9 +152,11 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int db/setting/sound/touch_feedback/vibration_level_bak "3" ##private key
 
        vconftool $GOPTION set -t string db/setting/sound/call/ringtone_path "${DEFAULT_CALL_TONE}"
+       vconftool $GOPTION set -t string db/setting/sound/call/ringtone_default_path "${DEFAULT_CALL_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/call/vibration_type "2"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/msg_ringtone_path        "${DEFAULT_NOTI_TONE}"
+       vconftool $GOPTION set -t string db/setting/sound/noti/ringtone_default_path    "${DEFAULT_NOTI_TONE}"
        vconftool $GOPTION set -t int db/setting/sound/noti/msg_alert_rep_type          "0"
 
        vconftool $GOPTION set -t string db/setting/sound/noti/email_ringtone_path      "${DEFAULT_NOTI_TONE}"
@@ -160,44 +168,20 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t string db/menu_widget/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
        vconftool $GOPTION set -t string db/idle_lock/bgset "/opt/share/settings/Wallpapers/Home_default.jpg"
 
-#resetTilt
-       vconftool $GOPTION set -t bool db/setting/use_tilt "1"
-       vconftool $GOPTION set -t int db/setting/tilt_sensitivity "3"
-       vconftool $GOPTION set -t bool db/setting/use_tilt_scroll "1"
-       vconftool $GOPTION set -t int db/setting/tilt_scroll_sensitivity "3"
-
-#resetPanning
-       vconftool $GOPTION set -t bool db/setting/use_panning "0"
-       vconftool $GOPTION set -t int db/setting/panning_sensitivity "3"
-       vconftool $GOPTION set -t bool db/setting/use_panning_browser "1"
-       vconftool $GOPTION set -t int db/setting/panning_browser_sensitivity "3"
-
-#resetDoubleTap
-       vconftool $GOPTION set -t bool db/setting/use_double_tap "1"
-
-#resetShake
-       vconftool $GOPTION set -t bool db/setting/use_shake "1"
-
-#resetPickup
-       vconftool $GOPTION set -t bool db/setting/use_pick_up "1"
-       vconftool $GOPTION set -t bool db/setting/use_pick_up_call "1"
-
-#resetTurnOver
-       vconftool $GOPTION set -t bool db/setting/use_turn_over "1"
-
 #resetMotions
        vconftool $GOPTION set -t bool db/setting/motion_active "1"
-       vconftool $GOPTION set -t bool db/setting/motion/palm_swipe_capture "1"
-       vconftool $GOPTION set -t bool db/setting/motion/palm_touch_mute "1"
-       vconftool $GOPTION set -t bool db/setting/motion/tap_twist "1"
 
 #resetDisplay
        #backlight
-%ifarch %{arm}
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
+# Set backlight timeout to dim display on all platforms except emulator
+# 0 sec : unlimited time
+# 600 sec : 10 min
+%if 0%{?simulator}
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "600"
 %else
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
 %endif
+
        vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
@@ -209,35 +193,9 @@ GOPTION="-g 6514"
        #launch
        #vconftool $GOPTION set -t string db/menu_widget/launch_effect "0"
 
-       #smart screen
-       vconftool $GOPTION set -t int db/pm/smartstay_status "0"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation "0"
-       vconftool $GOPTION set -t bool db/setting/auto_adjust_screen_tone "1"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_stay_r "1"
-       vconftool $GOPTION set -t bool db/setting/smartscreen/smart_rotation_r "1"
-
 #resetPowersaving
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/status "0"
        vconftool $GOPTION set -t bool db/setting/pwrsv/system_mode/reminder "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/status "0"
-
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/at "30"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/wifi "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bt "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/gps "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/data_sync "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/hotspot "1"
-
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/status  "1"
-       vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/brt/auto/status "0"
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/brt/value "10"
-       vconftool $GOPTION set -t int db/setting/pwrsv/custom_mode/backlight/time "15"
-
-       #v0.4
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/cpu "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/display "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/bg_color "0"
-        vconftool $GOPTION set -t bool db/setting/pwrsv/custom_mode/screen_vib "0"
 
 #resetFont
        vconftool $GOPTION set -t int db/setting/font_size "1"
@@ -245,6 +203,7 @@ GOPTION="-g 6514"
 
 #resetRotationLock
        vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
+       vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
        #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
 #resetTimeAndData
 %ifarch %{arm}
@@ -257,6 +216,13 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int db/setting/date_format "0"
        vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
 
+       #-----------------------------------------------------------------
+       # MOCK FUNCTION
+       # MOCK IMPLEMENTATION FOR API COMPATIBILITY
+       # NEED TO CHECK THE KEY WITH THE CALENDAR APP
+       #-----------------------------------------------------------------
+       vconftool $GOPTION set -t int db/setting/weekofday_format  "0"
+
        vconftool $GOPTION set -t string db/setting/timezone "+9"
        # to be removed
        vconftool $GOPTION set -t string db/setting/cityname_id "IDS_WCL_BODY_CITYNAME_SEOUL"
@@ -278,34 +244,18 @@ GOPTION="-g 6514"
        #vconftool $GOPTION set -t int db/setting/accessibility/font_style "0"
        vconftool $GOPTION set -t string db/setting/accessibility/font_name "HelveticaNeue"
        vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
+       vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
-       vconftool $GOPTION set -t bool db/setting/accessibility/torch_light "0"
-       vconftool $GOPTION set -t bool db/setting/accessibility/mono_audio "0"
-       vconftool $GOPTION set -t int db/setting/accessibility/power_key_hold "1"
-       vconftool $GOPTION set -t bool db/setting/accessibility/led_notify "0"
-
-       vconftool $GOPTION set -t bool db/ciss/call_answering_key "0"
-       vconftool $GOPTION set -t bool db/ciss/call_power_key_ends_call "0"
-       vconftool $GOPTION set -t int db/ciss/answering_mode "0"
-       vconftool $GOPTION set -t int db/ciss/answering_mode_time "3"
-
-       vconftool $GOPTION set -t bool db/setting/accessibility/accept_call "0"
-        vconftool $GOPTION set -t bool db/setting/accessibility/enable_auto_answer "0"
-        vconftool $GOPTION set -t int db/setting/accessibility/auto_answer "1"
-        vconftool $GOPTION set -t bool db/setting/accessibility/powerkey_end_calls "0"
-
-#Driving Mode
-       vconftool $GOPTION set -t bool db/setting/drivingmode/drivingmode "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/incomingcall "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/message "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/newemails "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/newvoicemails "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/alarm "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/schedule "1"
-       vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
+       #-----------------------------------------------------------------
+       # MOCK FUNCTION
+       # NOT SUPPORTED BUT ADDED FOR API COMPATIBILITY
+       # temp key for screen reader & speech rate
+       #-----------------------------------------------------------------
+       vconftool $GOPTION set -t bool db/setting/accessibility/tts "0"
+       vconftool $GOPTION set -t int db/setting/accessibility/speech_rate "2"
 
 #resetLanguageAndRegion
-       vconftool $GOPTION set -t int db/setting/lang "9"
+       vconftool $GOPTION set -t int db/setting/lang "10"
        vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
        vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
 
@@ -322,48 +272,15 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/expiry_reminder "0"
        vconftool $GOPTION set -t int db/setting/roaming_network "0"
 
-#resetNotification
-       vconftool $GOPTION set -t bool db/setting/ticker_noti/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/facebook "1"
-
-        # display content
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/display_content/facebook "1"
-
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/messages "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/email "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/im "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/twitter "1"
-        vconftool $GOPTION set -t bool db/setting/ticker_noti/badge/facebook "1"
-
 #resetSecurity
        rm -rf /opt/data/setting/set_info
        #vconftool $GOPTION set -t string db/setting/privacy_passwd ""
-
-       vconftool $GOPTION set -t bool db/setting/power_on_lock "0"
-       vconftool $GOPTION set -t bool db/setting/simple_password "1"
-       vconftool $GOPTION set -t int db/setting/screen_lock_type "0"
-       vconftool $GOPTION set -t bool db/setting/fmm/sim_change_alert "0"
-       vconftool $GOPTION set -t string db/setting/fmm/recipients ""
-       vconftool $GOPTION set -t string db/setting/fmm/sender ""
-       vconftool $GOPTION set -t string db/setting/fmm/alert_message ""
-       vconftool $GOPTION set -t bool db/setting/fmm/remote_control "0"
-       vconftool $GOPTION set -t bool db/setting/fmm/location_consent "0"
+       vconftool $GOPTION set -t int db/setting/screen_lock_type "5" -f
+       vconftool $GOPTION set -t string db/setting/3rd_lock_pkg_name "org.tizen.lockscreen"
 
        # NOT USED NOW.
        #vconftool $GOPTION set -t bool db/setting/rcs "0"
 
-       vconftool $GOPTION set -t int db/setting/phone_lock_attempts_left "5"
-       vconftool $GOPTION set -t string db/setting/phone_lock_timestamp ""
-       vconftool $GOPTION set -t int db/setting/sim_lock_attempts_left "5"
-       vconftool $GOPTION set -t string db/setting/sim_lock_timestamp ""
-       vconftool $GOPTION set -t bool db/setting/fixed_dialing_mode "0"
 #resetMemory
        vconftool $GOPTION set -t int db/setting/default_memory/wap "0"
        vconftool $GOPTION set -t int db/setting/default_memory/bluetooth "0"
@@ -387,12 +304,6 @@ GOPTION="-g 6514"
 #resetDevoptions
        vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
 
-#resetDatausage
-       vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
-       vconftool $GOPTION set -t int db/setting/data_limit "0"
-       vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
-       vconftool $GOPTION set -t int db/setting/data_each_month "1"
-
 #resetDisplay
        vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
 
@@ -414,6 +325,8 @@ sync
 mkdir -p /usr/ug/bin/
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-plugin-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-privacy-efl
 
 %files -n org.tizen.setting
 %manifest settings.manifest