Turn on the debugging option to enable SDB by default
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index b93375a..4841f31 100755 (executable)
@@ -12,11 +12,10 @@ BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(tapi)
 BuildRequires:  pkgconfig(utilX)
 BuildRequires:  pkgconfig(devman)
-BuildRequires:  pkgconfig(devman_haptic)
+BuildRequires:  pkgconfig(haptic)
 BuildRequires:  pkgconfig(bluetooth-api)
 BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(openssl)
-BuildRequires:  pkgconfig(heynoti)
 BuildRequires:  pkgconfig(ui-gadget-1)
 BuildRequires:  pkgconfig(json-glib-1.0)
 BuildRequires:  pkgconfig(libxml-2.0)
@@ -58,7 +57,6 @@ BuildRequires:  pkgconfig(capi-system-device)
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-sensor)
-BuildRequires:  pkgconfig(capi-system-haptic)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
@@ -77,9 +75,9 @@ Setting application
 
 %build
 
-%define PREFIX    "/opt/apps/org.tizen.setting"
-%define RESDIR    "/opt/apps/org.tizen.setting/res"
-%define DATADIR    "/opt/apps/org.tizen.setting/data"
+%define PREFIX    "/usr/apps/org.tizen.setting"
+%define RESDIR    "/usr/apps/org.tizen.setting/res"
+%define DATADIR    "/usr/apps/org.tizen.setting/data"
 CFLAGS+=" -fPIC";export CFLAGS
 CXXFLAGS+=" -fPIC";export CFLAGS
 LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";export LDFLAGS
@@ -124,13 +122,14 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
+       vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
        DEFAULT_NOTI_TONE="/opt/share/settings/Alerts/General notification_sdk.wav"
 
        vconftool $GOPTION set -t bool db/setting/sound/sound_on "1"
-       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "1"
+       vconftool $GOPTION set -t bool db/setting/sound/vibration_on "0"
 
        vconftool $GOPTION set -t int db/setting/sound/call/ringtone_sound_volume "13"
        vconftool $GOPTION set -t int db/setting/sound/noti/sound_volume "7"
@@ -301,7 +300,7 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
 
 #resetLanguageAndRegion
-       vconftool $GOPTION set -t int db/setting/lang "2"
+       vconftool $GOPTION set -t int db/setting/lang "10"
        vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
        vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
 
@@ -403,36 +402,35 @@ fi
 # create setting.cfg at runtime right after installation
 #/opt/apps/org.tizen.setting/bin/setting_conf_util
 # After flashing, initialize timezone file
-/opt/apps/org.tizen.setting/bin/setting_conf_util timezone_init
+/usr/apps/org.tizen.setting/bin/setting_conf_util timezone_init
 chown 5000:5000 /opt/data/setting -R
 #------------------------------------------
-heynotitool set setting_time_changed -a
 sync
 
-mkdir -p /opt/ug/bin/
-ln -sf /usr/bin/ug-client /opt/ug/bin/setting-font-efl
+mkdir -p /usr/ug/bin/
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
 # ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
 
 %files -n org.tizen.setting
-#%manifest settings.manifest
+%manifest settings.manifest
 %defattr(-,root,root,-)
 #%attr(-,inhouse,inhouse) %dir /opt/data/setting
 %attr(-,app,app) %dir /opt/data/setting
-/opt/apps/org.tizen.setting/bin/setting
-/opt/apps/org.tizen.setting/bin/setting_conf_util
+/usr/apps/org.tizen.setting/bin/setting
+/usr/apps/org.tizen.setting/bin/setting_conf_util
 /opt/data/setting/setting.cfg
 
-/opt/share/packages/org.tizen.setting.xml
-/opt/share/packages/ug-setting-accessibility-efl.xml
-/opt/share/packages/ug-setting-font-efl.xml
+/usr/share/packages/org.tizen.setting.xml
+/usr/share/packages/ug-setting-accessibility-efl.xml
+#/opt/share/packages/ug-setting-font-efl.xml
 
-/opt/share/icons/default/small/org.tizen.setting.png
+/usr/share/icons/default/small/org.tizen.setting.png
 /opt/share/settings/*
-/opt/apps/org.tizen.setting/res/*
-/opt/apps/org.tizen.setting/lib/*
-/opt/apps/org.tizen.setting/data/*
-/opt/ug/lib/*
+/usr/apps/org.tizen.setting/res/*
+/usr/apps/org.tizen.setting/lib/*
+/usr/apps/org.tizen.setting/data/*
+/usr/ug/lib/*
 /opt/data/setting/langlist.xml
 /opt/data/setting/plugin-cfg/*
 /opt/data/setting/plugin-xml/*
-/opt/apps/org.tizen.setting/bin/test_server
+/usr/apps/org.tizen.setting/bin/test_server