Merge "use correct conversion specifier in debug logging"
[apps/core/preloaded/settings.git] / packaging / org.tizen.setting.spec
index ad3d21b..1baad96 100755 (executable)
@@ -3,7 +3,7 @@ Summary:    Setting application
 Version:    0.1.87
 Release:    99
 Group:      misc
-License:    samsung
+License:    Flora License, Version 1
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  pkgconfig(appcore-common)
 BuildRequires:  pkgconfig(appcore-efl)
@@ -42,11 +42,11 @@ BuildRequires:  pkgconfig(ewebkit2)
 BuildRequires:  pkgconfig(evas)
 BuildRequires:  pkgconfig(edje)
 BuildRequires:  pkgconfig(mm-player)
-BuildRequires:  pkgconfig(network)
-BuildRequires:  pkgconfig(security-server)
+BuildRequires:  pkgconfig(capi-network-connection)
+#BuildRequires:  pkgconfig(network)
+#BuildRequires:  pkgconfig(security-server)
 BuildRequires:  pkgconfig(svi)
 BuildRequires:  pkgconfig(appsvc)
-BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(notification)
 BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(capi-system-runtime-info)
@@ -59,12 +59,18 @@ BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(capi-system-sensor)
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-system-settings)
+BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth)
+BuildRequires:  pkgconfig(capi-network-tethering)
+BuildRequires:  pkgconfig(capi-network-nfc)
+BuildRequires:  pkgconfig(ecore-evas)
 BuildRequires:  pkgconfig(pkgmgr)
 BuildRequires:  sysman-internal-devel
 BuildRequires:  cmake
 BuildRequires:  edje-tools
 BuildRequires:  gettext-tools
+#Requires: org.tizen.phone
+Requires: ug-bluetooth-efl
 %description
 Setting application
  BEAT UI, Setting application.
@@ -88,6 +94,7 @@ LDFLAGS+="-Wl,--rpath=%{PREFIX}/lib -Wl,--hash-style=both -Wl,--as-needed";expor
        cmake . -DCMAKE_INSTALL_PREFIX=%{PREFIX} -DARCH=x86
 %endif
 
+make clean
 make
 
 %install
@@ -109,7 +116,7 @@ GOPTION="-g 6514"
 
 
 #resetFlightmode
-       vconftool $GOPTION set -t bool db/setting/flight_mode "0"
+       vconftool $GOPTION set -t bool db/telephony/flight_mode "0" -f
 
 #resetNetwork
        vconftool $GOPTION set -t int db/setting/select_network "0"
@@ -122,7 +129,7 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t int memory/setting/usb_mode "-1" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_sel_mode "0" -i -f
        vconftool $GOPTION set -t int memory/setting/usb_in_mode_change "0" -i -f
-       vconftool $GOPTION set -t bool db/setting/debug_mode "0" -f
+       vconftool $GOPTION set -t bool db/setting/debug_mode "1" -f
 
 #resetSound
        DEFAULT_CALL_TONE="/opt/share/settings/Ringtones/ringtone_sdk.mp3"
@@ -188,11 +195,13 @@ GOPTION="-g 6514"
 
 #resetDisplay
        #backlight
-%ifarch %{arm}
-       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
-%else
+# Set backlight timeout to dim display on all platforms except emulator
+%if 0%{?simulator}
        vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "0"
+%else
+       vconftool $GOPTION set -t int db/setting/lcd_backlight_normal "30"
 %endif
+
        vconftool $GOPTION set -t int db/setting/lcd_timeout_normal_backup "30"
 
        #brightness
@@ -240,7 +249,8 @@ GOPTION="-g 6514"
 
 #resetRotationLock
        vconftool $GOPTION set -t bool db/setting/rotate_lock "1"
-
+       vconftool $GOPTION set -t bool db/setting/auto_rotate_screen "0"
+       #vconftool $GOPTION set -t bool memory/setting/rotate_hold "0" -i -f
 #resetTimeAndData
 %ifarch %{arm}
        vconftool $GOPTION set -t bool db/setting/automatic_time_update "1"
@@ -300,9 +310,9 @@ GOPTION="-g 6514"
        vconftool $GOPTION set -t bool db/setting/drivingmode/unlockscreen "1"
 
 #resetLanguageAndRegion
-       vconftool $GOPTION set -t int db/setting/lang "10"
-       vconftool $GOPTION set -t string db/menu_widget/language "en_US.UTF-8"
-       vconftool $GOPTION set -t string db/menu_widget/regionformat "en_US.UTF-8"
+       vconftool $GOPTION set -t int db/setting/lang "9"
+       vconftool $GOPTION set -t string db/menu_widget/language "en_GB.UTF-8"
+       vconftool $GOPTION set -t string db/menu_widget/regionformat "en_GB.UTF-8"
 
 #resetViewtype
        #vconftool $GOPTION set -t int db/menuscreen/viewtype "0"
@@ -383,11 +393,10 @@ GOPTION="-g 6514"
        vconftool $GOPTION -i set -t int db/setting/devoption/bgprocess "0"
 
 #resetDatausage
-       vconftool $GOPTION set -t bool db/setting/mobile_data "1"
-       vconftool $GOPTION set -t bool db/setting/disable_mobile_data_at_limit "0"
-       vconftool $GOPTION set -t bool db/setting/restrict_background_data "0"
-       vconftool $GOPTION set -t bool db/setting/show_wifi_usage "0"
-       vconftool $GOPTION set -t int db/setting/data_each_month "10"
+       vconftool $GOPTION set -t bool db/setting/set_data_usage_limit "0"
+       vconftool $GOPTION set -t int db/setting/data_limit "0"
+       vconftool $GOPTION set -t int db/setting/data_usage_cycle "0"
+       vconftool $GOPTION set -t int db/setting/data_each_month "1"
 
 #resetDisplay
        vconftool $GOPTION set -t string db/setting/screenmode/selected_name "Dynamic"
@@ -409,7 +418,7 @@ sync
 
 mkdir -p /usr/ug/bin/
 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
-# ln -sf /usr/bin/ug-client /opt/ug/bin/setting-accessibility-efl
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-profile-efl
 
 %files -n org.tizen.setting
 %manifest settings.manifest
@@ -421,8 +430,6 @@ ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
 /opt/data/setting/setting.cfg
 
 /usr/share/packages/org.tizen.setting.xml
-/usr/share/packages/ug-setting-accessibility-efl.xml
-#/opt/share/packages/ug-setting-font-efl.xml
 
 /usr/share/icons/default/small/org.tizen.setting.png
 /opt/share/settings/*
@@ -433,4 +440,4 @@ ln -sf /usr/bin/ug-client /usr/ug/bin/setting-font-efl
 /opt/data/setting/langlist.xml
 /opt/data/setting/plugin-cfg/*
 /opt/data/setting/plugin-xml/*
-/usr/apps/org.tizen.setting/bin/test_server
+#/usr/apps/org.tizen.setting/bin/test_server