Merge branch 'tizen_3.0' into tizen
[platform/core/uifw/inputmethod-setting.git] / packaging / org.tizen.inputmethod-setting.spec
index a61b995..c14c939 100644 (file)
@@ -1,20 +1,21 @@
 Name:       org.tizen.inputmethod-setting
 Summary:    Input Method Setting Application
-Version:    0.5.23
+Version:    0.5.24
 Release:    1
 Group:      Graphics & UI Framework/Input
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 
 BuildRequires:  gettext-tools
+BuildRequires:  cmake
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(isf)
 BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(dlog)
-BuildRequires:  cmake
-BuildRequires:  efl-extension-devel
+BuildRequires:  pkgconfig(efl-extension)
 BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(capi-ui-inputmethod-manager)
+BuildRequires:  pkgconfig(capi-appfw-package-manager)
 Requires:      %{name}-compat = %{version}-%{release}
 # This if/endif is for GBM build optimization. This usage does not affect
 # The unified build (profile is undefined) as it will return TRUE always.
@@ -108,8 +109,7 @@ CFLAGS="$CFLAGSBASE -D_MOBILE"
 CXXFLAGS="$CXXFLAGSBASE -D_MOBILE"
 
 pushd build_mobile
-cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
+%cmake .. -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
          -DTZ_SYS_RO_ICONS=%TZ_SYS_RO_ICONS
 make %{?jobs:-j%jobs}
@@ -124,8 +124,7 @@ mkdir -p build_wearable_rectangle
 CFLAGS="$CFLAGSBASE -D_WEARABLE"
 CXXFLAGS="$CXXFLAGSBASE -D_WEARABLE"
 pushd build_wearable_rectangle
-cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
+%cmake .. -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
          -DTZ_SYS_RO_ICONS=%TZ_SYS_RO_ICONS
 make %{?jobs:-j%jobs}
@@ -138,8 +137,7 @@ mkdir -p build_wearable_circle
 CFLAGS="$CFLAGSBASE -D_WEARABLE -D_CIRCLE"
 CXXFLAGS="$CXXFLAGSBASE -D_WEARABLE -D_CIRCLE"
 pushd build_wearable_circle
-cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
+%cmake .. -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
          -DTZ_SYS_RO_ICONS=%TZ_SYS_RO_ICONS
 make %{?jobs:-j%jobs}
@@ -152,8 +150,7 @@ popd
 %if "%{?profile}"!="mobile" && "%{?profile}"!="wearable"
 CFLAGS="$CFLAGSBASE"
 CXXFLAGS="$CXXFLAGSBASE"
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-        -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
+%cmake . -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
         -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
         -DTZ_SYS_RO_ICONS=%TZ_SYS_RO_ICONS
 make %{?jobs:-j%jobs}