Revert "Remove unused dependencies"
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
index efc6250..5b90eb8 100755 (executable)
@@ -1,6 +1,15 @@
+# For the backward compatibility, this is to be built for
+# wearable profile or 4.0 unified building environment.
+# This cannot be built for non-wearable in conventional 3.0 build environment.
+# Note that it is not a good idea to limit building with ExcludeArch because there are new architectures being tested.
+# Use ExclusiveArch istead.
+%if "%{?profile}" == "mobile" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "common"
+ExclusiveArch:  none
+%endif
+
 Name: org.tizen.inputdelegator
 Summary: Input Delegator Application
-Version: 0.1.160927
+Version: 0.1.170316
 Release: 1
 Group: Applications
 License: Apache-2.0
@@ -16,10 +25,12 @@ BuildRequires:  pkgconfig(edbus)
 
 BuildRequires: cmake
 BuildRequires: edje-bin
-BuildRequires: gettext
+BuildRequires: gettext-tools
 
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(capi-appfw-application)
+BuildRequires: pkgconfig(capi-appfw-app-control)
+BuildRequires: pkgconfig(capi-appfw-preference)
 BuildRequires: pkgconfig(capi-media-wav-player)
 BuildRequires: pkgconfig(capi-system-device)
 BuildRequires: pkgconfig(eina)
@@ -31,28 +42,12 @@ BuildRequires: pkgconfig(vconf)
 BuildRequires: pkgconfig(db-util)
 BuildRequires: pkgconfig(sqlite3)
 BuildRequires: pkgconfig(capi-media-audio-io)
-
+BuildRequires: pkgconfig(smartreply)
 
 %if %{enable_log_manager}
 BuildRequires:  pkgconfig(bundle)
 %endif
 
-%if "%{?profile}" == "mobile"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "tv"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "common"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
-%if "%{?profile}" == "ivi"
-ExcludeArch: %{arm} aarch64 %ix86 x86_64
-%endif
-
 %define _appdir                /usr/apps
 %define _app_destdir   %{_appdir}/%{name}
 
@@ -67,11 +62,9 @@ Input Delegator Application for Wearable environment
 %setup -q
 
 %build
-%if 0%{?sec_build_binary_debug_enable}
-export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
-export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
+export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden"
+export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden -fvisibility-inlines-hidden"
 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
-%endif
 
 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"