Update package version to 0.0.160704
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
index f87a163..536be3b 100755 (executable)
@@ -1,6 +1,6 @@
 Name: org.tizen.inputdelegator
 Summary: Input Delegator Application
-Version: 0.0.160629
+Version: 0.0.160704
 Release: 1
 Group: Applications
 License: Apache-2.0
@@ -38,6 +38,21 @@ BuildRequires: pkgconfig(sqlite3)
 BuildRequires:  pkgconfig(bundle)
 %endif
 
+%if "%{?profile}" == "mobile"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{?profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{?profile}" == "common"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{?profile}" == "ivi"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
 
 %define _appdir                /usr/apps
 %define _app_destdir   %{_appdir}/%{name}
@@ -54,9 +69,9 @@ Input Delegator Application for Wearable environment
 
 %build
 %if 0%{?sec_build_binary_debug_enable}
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
+export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
+export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
 %endif
 
 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"