Do not update twice even if it exceed update period in pause.
[platform/framework/web/data-provider-slave.git] / packaging / org.tizen.data-provider-slave.spec
index 6de4d27..e123c3e 100644 (file)
@@ -1,14 +1,18 @@
+%define app_data /opt/usr/apps/org.tizen.data-provider-slave/data
+
 Name: org.tizen.data-provider-slave
-Summary: Slave data provider
-Version: 0.8.13
+Summary: Plugin type livebox service provider
+Version: 0.12.20
 Release: 1
-Group: main/app
-License: Flora License
+Group: HomeTF/Livebox
+License: Flora
 Source0: %{name}-%{version}.tar.gz
-BuildRequires: cmake, gettext-tools
+Source1001: %{name}.manifest
+BuildRequires: cmake, gettext-tools, coreutils, edje-bin
 BuildRequires: pkgconfig(appcore-efl)
 BuildRequires: pkgconfig(ail)
 BuildRequires: pkgconfig(dlog)
+BuildRequires: pkgconfig(appsvc)
 BuildRequires: pkgconfig(aul)
 BuildRequires: pkgconfig(vconf)
 BuildRequires: pkgconfig(sqlite3)
@@ -27,28 +31,53 @@ BuildRequires: pkgconfig(edje)
 BuildRequires: pkgconfig(evas)
 BuildRequires: pkgconfig(livebox)
 BuildRequires: pkgconfig(elementary)
+BuildRequires: pkgconfig(com-core)
+BuildRequires: pkgconfig(shortcut)
+BuildRequires: pkgconfig(capi-system-system-settings)
+BuildRequires: hash-signer
+Requires: data-provider-master
 
 %description
-Loading livebox and managing their life-cycle to generate contents properly.
+Plugin type liveboxes are managed by this.
+Supporting the EFL.
+Supporting the In-house livebox only.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
-#-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
-CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
+export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
+%endif
+
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
 %make_install
-mkdir -p %{buildroot}/usr/share/license
+%define tizen_sign 1
+%define tizen_sign_base %{_prefix}/apps/org.tizen.data-provider-slave
+%define tizen_sign_level platform
+%define tizen_author_sign 1
+%define tizen_dist_sign 1
+mkdir -p %{buildroot}/%{_datarootdir}/license
+mkdir -p %{buildroot}%{app_data}
 
 %post
+chown 5000:5000 %{app_data}
+chmod 755 %{app_data}
 
 %files -n org.tizen.data-provider-slave
-%manifest org.tizen.data-provider-slave.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
-/usr/apps/org.tizen.data-provider-slave/bin/data-provider-slave
-/usr/share/packages/org.tizen.data-provider-slave.xml
-/usr/share/license/*
+%{_prefix}/apps/org.tizen.data-provider-slave
+%{_datarootdir}/packages/%{name}.xml
+%{_datarootdir}/license/*
+%{_sysconfdir}/smack/accesses.d/%{name}.rule
+%dir %{app_data}
+
+# End of a file