remove build warning and clean up spec file
[apps/native/bluetooth-share-ui.git] / packaging / org.tizen.bluetooth-share-ui.spec
index 76d6821..cc13da3 100755 (executable)
@@ -30,7 +30,7 @@ BuildRequires:  edje-tools
 BuildRequires:  gettext-devel
 BuildRequires:  hash-signer
 
-%define PKG_NAME org.tizen.bluetooth-share-ui
+%define PKG_NAME %{name}
 
 %description
 bluetooth share UI application
@@ -40,11 +40,6 @@ bluetooth share UI application
 %setup -q
 
 %build
-export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
-
-export CFLAGS="$CFLAGS -DTIZEN_EFL_THEME_2.2"
 export CFLAGS+=" -fpie -fvisibility=hidden"
 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
 
@@ -55,7 +50,7 @@ make %{?jobs:-j%jobs}
 %install
 rm -rf %{buildroot}
 %make_install
-PKG_ID=org.tizen.bluetooth-share-ui
+PKG_ID=%{name}
 %define tizen_sign 1
 %define tizen_sign_base /usr/apps/${PKG_ID}
 %define tizen_sign_level platform
@@ -74,11 +69,11 @@ PKG_ID=org.tizen.bluetooth-share-ui
 %manifest bluetooth-share-ui.manifest
 %license LICENSE
 %defattr(-,root,root,-)
-%{_appdir}/org.tizen.bluetooth-share-ui/res/edje/bt-share-layout.edj
-%{_appdir}/org.tizen.bluetooth-share-ui/res/edje/images.edj
-%{_appdir}/org.tizen.bluetooth-share-ui/bin/bluetooth-share-ui
-%{_appdir}/org.tizen.bluetooth-share-ui/author-signature.xml
-%{_appdir}/org.tizen.bluetooth-share-ui/signature1.xml
-%{_usrdir}/share/icons/default/small/org.tizen.bluetooth-share-ui.png
-%{_usrdir}/share/packages/org.tizen.bluetooth-share-ui.xml
+%{_appdir}/%{name}/res/edje/bt-share-layout.edj
+%{_appdir}/%{name}/res/edje/images.edj
+%{_appdir}/%{name}/bin/bluetooth-share-ui
+%{_appdir}/%{name}/author-signature.xml
+%{_appdir}/%{name}/signature1.xml
+%{_usrdir}/share/icons/default/small/%{name}.png
+%{_usrdir}/share/packages/%{name}.xml