Fix RPMLINT error
[platform/core/system/oma-ds-agent.git] / packaging / oma-ds-agent.spec
index d3fbf7b..9cf9177 100755 (executable)
@@ -1,5 +1,5 @@
 Name:       oma-ds-agent
-Summary:    oma-ds-agent daemon for data sync
+Summary:    OMA-DS Agent Daemon for Data Synchronization
 Version:    0.1.66
 Release:    1
 Group:      Base/Device Management
@@ -72,21 +72,8 @@ then
        mkdir /etc/rc.d/rc5.d
 fi
 
-if [ ! -f /etc/rc.d/rc3.d/S91oma-ds-agent ]
-then
-ln -s /etc/init.d/oma-ds /etc/rc.d/rc3.d/S91oma-ds-agent
-fi
-
-if [ ! -f /etc/rc.d/rc5.d/S91oma-ds-agent ]
-then
-       ln -s /etc/init.d/oma-ds /etc/rc.d/rc5.d/S91oma-ds-agent
-fi
-
-#/etc/init.d/oma-ds start
-
 
 %preun
-/etc/init.d/oma-ds stop
 
 
 %postun
@@ -108,17 +95,16 @@ rm -rf /usr/share/oma-ds-cfg
 
 %manifest oma-ds-agent.manifest
 %defattr(-,root,root,-)
-/usr/share/dbus-1/services/*
+/usr/share/dbus-1/system-services/com.samsung.omadsagent.service
 /usr/bin/oma-ds-agent
 
 /usr/share/oma-ds-cfg/*
 
 %defattr(700,root,root)
-/etc/init.d/oma-ds
-
 %defattr(644,root,root)
 /usr/lib/systemd/system/oma-ds-agent.service
 /usr/lib/systemd/system/graphical.target.wants/oma-ds-agent.service
+/etc/dbus-1/system.d/com.samsung.omadsagent.conf
 
 %files -n ds-public-plugins
 %manifest ds-public-plugins.manifest