fix the spec
[profile/ivi/ofono.git] / packaging / ofono.spec
index ee8a23a..dd77df3 100644 (file)
@@ -1,19 +1,12 @@
 Name:       ofono
 Summary:    Open Source Telephony
-Version:    1.6
+Version:    1.8
 Release:    6
 Group:      Communications/Connectivity Adaptation
 License:    GPLv2
 URL:        http://ofono.org
 Source0:    %{name}-%{version}.tar.bz2
 Source1:    init_ofono
-Patch0:     0001-ifxmodem-Add-support-for-IPv6-and-dual-mode-contexts.patch
-Patch1:     0002-ifxmodem-Add-support-for-dynamic-DNS-for-IPv6-and-du.patch
-Patch2:     0003-ifx-Setup-CSCS-to-use-GSM-for-the-aux-port.patch
-Patch3:     0004-atmodem-Fix-handling-of-IFX-signal-strength-indicati.patch
-Patch4:     0005-call-volume.c-Register-the-call-volume-interface-jus.patch
-Patch5:     0006-gisi-Remove-includes-of-glib-gtypes.h.patch
-Patch6:     0007-isimodem-Remove-includes-of-glib-gtypes.h.patch
 
 Requires(post): /bin/ln
 Requires:   dbus
@@ -43,6 +36,9 @@ Development headers and libraries for oFono
 Summary:    Test Scripts for oFono
 Group:      Development/Libraries
 Requires:   %{name} = %{version}-%{release}
+Requires:   dbus-python
+Requires:   pygobject
+Requires:   python-xml
 
 %description test
 Scripts for testing oFono and its functionality
@@ -50,53 +46,40 @@ Scripts for testing oFono and its functionality
 
 %prep
 %setup -q -n %{name}-%{version}
-# 0001-ifxmodem-Add-support-for-IPv6-and-dual-mode-contexts.patch
-%patch0 -p1
-# 0002-ifxmodem-Add-support-for-dynamic-DNS-for-IPv6-and-du.patch
-%patch1 -p1
-# 0003-ifx-Setup-CSCS-to-use-GSM-for-the-aux-port.patch
-%patch2 -p1
-# 0004-atmodem-Fix-handling-of-IFX-signal-strength-indicati.patch
-%patch3 -p1
-# 0005-call-volume.c-Register-the-call-volume-interface-jus.patch
-%patch4 -p1
-# 0001-gisi-Remove-includes-of-glib-gtypes.h.patch
-%patch5 -p1
-# 0002-isimodem-Remove-includes-of-glib-gtypes.h.patch
-%patch6 -p1
 
 %build
 autoreconf --force --install
 
 %configure --disable-static \
     --enable-test \
-    --with-systemdunitdir="/%{_lib}/systemd/system"
+    --with-systemdunitdir="/usr/lib/systemd/system"
 
 make %{?jobs:-j%jobs}
 
 %install
 %make_install
 
-mkdir -p %{buildroot}/%{_lib}/systemd/system/network.target.wants
-ln -s ../ofono.service %{buildroot}/%{_lib}/systemd/system/network.target.wants/ofono.service
-
-mkdir -p %{buildroot}/etc/rc.d/init.d
-cp %{SOURCE1} %{buildroot}/etc/rc.d/init.d/ofono
-chmod +x %{buildroot}/etc/rc.d/init.d/ofono
+mkdir -p %{buildroot}/usr/lib/systemd/system/network.target.wants
+ln -s ../ofono.service %{buildroot}/usr/lib/systemd/system/network.target.wants/ofono.service
 
 %post
-ln -sf ../init.d/ofono /etc/rc.d/rc3.d/S61ofono
-ln -sf ../init.d/ofono /etc/rc.d/rc5.d/S61ofono
+systemctl daemon-reload
+systemctl restart ofono.service
+
+%preun
+systemctl stop ofono.service
+
+%postun
+systemctl daemon-reload
 
 %docs_package
 
 %files
 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/*.conf
 %{_sbindir}/*
-/%{_lib}/systemd/system/network.target.wants/ofono.service
-/%{_lib}/systemd/system/ofono.service
+/usr/lib/systemd/system/network.target.wants/ofono.service
+/usr/lib/systemd/system/ofono.service
 /etc/ofono/phonesim.conf
-/etc/rc.d/init.d/*
 
 %files devel
 %{_includedir}/ofono/*.h