Add metafile backup script for softreset
[platform/core/security/ode.git] / packaging / ode.spec
index ab1305d..8f05da7 100755 (executable)
@@ -22,6 +22,7 @@ BuildRequires: pkgconfig(blkid)
 Requires: cryptsetup
 
 %global key_storage_plugin_dir %{_libdir}/ode-key-storage-plugin/
+%global softreset_dir /usr/system/RestoreDir/softreset/
 
 %description
 The ode package provides a daemon which is responsible for encrypting/decryption storages and secure erasing.
@@ -33,6 +34,7 @@ The ode package provides a daemon which is responsible for encrypting/decryption
 %{_unitdir}/ode.service
 %{_unitdir}/multi-user.target.wants/ode.service
 %attr(700,root,root) %{TZ_SYS_SBIN}/ode-admin-cli
+%attr(700,root,root) %{softreset_dir}/ode_softreset.sh
 %attr(750,root,system_share) %{TZ_SYS_SBIN}/ode-fota
 %{_datadir}/%{name}
 %dir %{key_storage_plugin_dir}
@@ -56,6 +58,7 @@ The ode package provides a daemon which is responsible for encrypting/decryption
          -DSYSTEMD_UNIT_DIR=%{_unitdir} \
          -DAPP_INSTALL_PREFIX="%{TZ_SYS_RO_APP}" \
          -DAPP_SHARE_PACKAGES_DIR="%{TZ_SYS_RO_PACKAGES}" \
+         -DSOFTRESET_DIR="%{softreset_dir}" \
          -DKEY_STORAGE_PLUGIN_DIR="%{key_storage_plugin_dir}"
 
 make %{?jobs:-j%jobs}