Fix typo in nfc-client-lib-neard-devel Requires
[platform/core/connectivity/nfc-manager-neard.git] / packaging / nfc-manager-neard.spec
index 077f234..2303fed 100755 (executable)
@@ -1,3 +1,6 @@
+%bcond_with wayland    1
+%bcond_with x
+
 Name:       nfc-manager-neard
 Summary:    NFC framework manager
 Version:    0.1.6
@@ -27,7 +30,12 @@ BuildRequires:  pkgconfig(libssl)
 BuildRequires:  pkgconfig(libcurl)
 BuildRequires:  pkgconfig(pkgmgr)
 BuildRequires:  pkgconfig(pkgmgr-info)
-BuildRequires:  pkgconfig(ecore-x)
+%if %{with x}
+BuildRequires: pkgconfig(ecore-x)
+%endif
+%if %{with wayland}
+BuildRequires: pkgconfig(ecore-wayland)
+%endif
 BuildRequires:  pkgconfig(pmapi)
 BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(neardal)
@@ -75,7 +83,7 @@ NFC manager Client library for NFC client applications.
 %package -n nfc-client-lib-neard-devel
 Summary:    NFC client library (devel)
 Group:      Network & Connectivity/Development
-Requires:   nfc-client-lib = %{version}
+Requires:   nfc-client-lib-neard = %{version}
 
 
 %description -n nfc-client-lib-neard-devel
@@ -95,7 +103,17 @@ NFC manager Client library for developing NFC client applications.
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
-%cmake . -DMAJORVER=${MAJORVER} -DFULLVER=%{version} %{?ARM_DEF}
+%cmake . -DMAJORVER=${MAJORVER} -DFULLVER=%{version} %{?ARM_DEF} \
+%if %{with wayland}
+-DWAYLAND_SUPPORT=On \
+%else
+-DWAYLAND_SUPPORT=Off \
+%endif
+%if %{with x}
+-DX11_SUPPORT=On
+%else
+-DX11_SUPPORT=Off
+%endif
 
 
 %install