delete upgrade script because no need data migration
[platform/core/messaging/msg-service.git] / packaging / msg-service.spec
index 875e5a1..f8947aa 100755 (executable)
@@ -1,5 +1,5 @@
 Name:           msg-service
-Version:        1.0.2
+Version:        1.0.9
 Release:        2
 License:        Apache-2.0
 Summary:        Messaging Framework Library
@@ -15,10 +15,10 @@ Requires(post): systemd
 Requires(postun): systemd
 Requires: acl
 Requires: security-config
+BuildRequires: boost-devel
 BuildRequires: cmake
 BuildRequires: pkgconfig(alarm-service)
 BuildRequires: pkgconfig(aul)
-BuildRequires: pkgconfig(boost)
 BuildRequires: pkgconfig(bundle)
 BuildRequires: pkgconfig(capi-media-image-util)
 BuildRequires: pkgconfig(capi-media-metadata-extractor)
@@ -27,6 +27,7 @@ BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(capi-system-device)
 BuildRequires: pkgconfig(capi-system-info)
 BuildRequires: pkgconfig(capi-telephony)
+BuildRequires: pkgconfig(contacts-service2)
 BuildRequires: pkgconfig(csr)
 BuildRequires: pkgconfig(cynara-client)
 BuildRequires: pkgconfig(cynara-creds-commons)
@@ -47,18 +48,16 @@ BuildRequires: pkgconfig(libtzplatform-config)
 BuildRequires: pkgconfig(libxml-2.0)
 BuildRequires: pkgconfig(libwbxml2)
 BuildRequires: pkgconfig(motion)
+BuildRequires: pkgconfig(phonenumber-utils)
 BuildRequires: pkgconfig(sqlite3)
 BuildRequires: pkgconfig(tapi)
 BuildRequires: pkgconfig(vconf)
-%if "%{?profile}" != "wearable"
-BuildRequires: pkgconfig(contacts-service2)
-%endif
-%if "%{?profile}" == "mobile"
+# Below BuildRequires-statements are only for msg-manager
 BuildRequires: gettext-tools
 BuildRequires: hash-signer
 BuildRequires: pkgconfig(badge)
 BuildRequires: pkgconfig(callmgr_client)
-BuildRequires: pkgconfig(capi-appfw-application)
+BuildRequires: pkgconfig(capi-appfw-event)
 BuildRequires: pkgconfig(capi-appfw-package-manager)
 BuildRequires: pkgconfig(capi-appfw-service-application)
 BuildRequires: pkgconfig(capi-media-player)
@@ -66,12 +65,10 @@ BuildRequires: pkgconfig(capi-media-sound-manager)
 BuildRequires: pkgconfig(capi-media-recorder)
 BuildRequires: pkgconfig(feedback)
 BuildRequires: pkgconfig(notification)
-%endif
 
 %description
 Description: Messaging Framework Library
 
-
 %package devel
 License:        Apache-2.0
 Summary:        Messaging Framework Library (development)
@@ -81,20 +78,6 @@ Group:          Development/Libraries
 %description devel
 Description: Messaging Framework Library (development)
 
-
-%package tools
-License:        Apache-2.0
-Summary:        Messaging server application
-Requires:       %{name} = %{version}-%{release}
-Group:          System/Libraries
-Requires(post): /usr/bin/sqlite3
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
-
-%description tools
-Description:  Messaging server application
-
-
 %package -n sms-plugin
 License:        Apache-2.0
 Summary:        SMS plugin library
@@ -126,13 +109,15 @@ Group:          Applications/Messaging
 %description -n msg-manager
 Description: Message manager application
 
-%if "%{?profile}" == "mobile"
 %define APP_PKGNAME    org.tizen.msg-manager
 %define APP_PREFIX     %{TZ_SYS_RO_APP}/%{APP_PKGNAME}
-%define APP_BINDIR     %{APP_PREFIX}/bin
 %define APP_RESDIR     %{APP_PREFIX}/res
 %define APP_LOCALEDIR  %{APP_RESDIR}/locale
-%define APP_MANIFESTDIR        %{TZ_SYS_RO_PACKAGES}
+
+%ifarch i586
+%define i586_option    "-D_TIZEN_I586_ENABLED:BOOL=ON"
+%else
+%define i586_option    "-D_TIZEN_I586_ENABLED:BOOL=OFF"
 %endif
 
 %prep
@@ -141,40 +126,21 @@ Description: Message manager application
 %build
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
                -DLIB_INSTALL_DIR=%{_libdir} \
-%if "%{?profile}" == "mobile"
-               -DAPP_MANIFESTDIR=%{APP_MANIFESTDIR}   \
-               -DAPP_BINDIR=%{APP_BINDIR}   \
-               -DAPP_LOCALEDIR=%{APP_LOCALEDIR}   \
-%endif
+               -DAPP_MANIFESTDIR=%{TZ_SYS_RO_PACKAGES}   \
+               -DAPP_BINDIR=%{APP_PREFIX}/bin   \
+               -DAPP_LOCALEDIR=%{APP_RESDIR}/locale \
                -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
                -DTZ_SYS_GLOBALUSER_DATA=%TZ_SYS_GLOBALUSER_DATA \
                -DTZ_SYS_GLOBALUSER_DB=%TZ_SYS_GLOBALUSER_DB \
                -DTZ_SYS_HOME=%TZ_SYS_HOME \
                -DTZ_SYS_BIN=%TZ_SYS_BIN \
-%ifarch i586
--D_TIZEN_I586_ENABLED:BOOL=ON \
-%else
--D_TIZEN_I586_ENABLED:BOOL=OFF \
-%endif
-%if "%{?profile}" == "wearable"
--D_MSG_WEARABLE_PROFILE:BOOL=ON \
-%else
--D_MSG_WEARABLE_PROFILE:BOOL=OFF \
-%endif
-%if "%{?profile}" == "mobile"
--D_MSG_MOBILE_PROFILE:BOOL=ON \
-%else
--D_MSG_MOBILE_PROFILE:BOOL=OFF \
-%endif
+               %{i586_option}
 
 make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
-mkdir -p %{buildroot}/usr/share/license
 mkdir -p %{buildroot}/etc/config
-mkdir -p %{buildroot}/usr/share/upgrade/scripts
-cp -f 500.msg-service.patch.sh %{buildroot}/usr/share/upgrade/scripts
 
 %make_install
 
@@ -200,7 +166,10 @@ rm %{buildroot}/usr/share/msg-service/msg-service-db.sql
 rm %{buildroot}%{TZ_SYS_GLOBALUSER_DB}/.msg_service.db-journal
 touch %{buildroot}%{TZ_SYS_GLOBALUSER_DB}/.msg_service.db-journal
 
-%post tools
+%post -n sms-plugin -p /sbin/ldconfig
+%post -n mms-plugin -p /sbin/ldconfig
+
+%post
 /sbin/ldconfig
 
 chmod 640 %{TZ_SYS_GLOBALUSER_DB}/.msg_service.db
@@ -237,21 +206,16 @@ chsmack -a "System::Shared" %{TZ_SYS_GLOBALUSER_DATA}/msg-service/msgdata/thumbn
 chmod o= %{TZ_SYS_GLOBALUSER_DATA}/msg-service/ipcdata
 setfacl -m group:priv_message_write:rw %{TZ_SYS_GLOBALUSER_DATA}/msg-service/ipcdata
 
-%post -n sms-plugin -p /sbin/ldconfig
-%post -n mms-plugin -p /sbin/ldconfig
-
-%post
-/sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
-%postun tools -p /sbin/ldconfig
 %postun -n sms-plugin -p /sbin/ldconfig
 %postun -n mms-plugin -p /sbin/ldconfig
 
 %files
 %manifest msg-service.manifest
 %license LICENSE.APLv2
+%config(noreplace) %{TZ_SYS_GLOBALUSER_DB}/.msg_service.db*
 %{_bindir}/msg-server
 %{_libdir}/libmsg_plugin_manager.so
 %{_libdir}/libmsg_mapi.so.*
@@ -261,7 +225,10 @@ setfacl -m group:priv_message_write:rw %{TZ_SYS_GLOBALUSER_DATA}/msg-service/ipc
 %{_libdir}/libmsg_externals.so
 %{_libdir}/libmsg_transaction_proxy.so
 %{_libdir}/libmsg_vobject.so
-/usr/share/upgrade/scripts/500.msg-service.patch.sh
+%{_unitdir}/msg-server.service
+%{_unitdir}/multi-user.target.wants/msg-server.service
+%{_unitdir}/msg-server.socket
+%{_unitdir}/sockets.target.wants/msg-server.socket
 
 %files devel
 %license LICENSE.APLv2
@@ -269,15 +236,6 @@ setfacl -m group:priv_message_write:rw %{TZ_SYS_GLOBALUSER_DATA}/msg-service/ipc
 %{_libdir}/pkgconfig/msg-service.pc
 %{_includedir}/msg-service/*
 
-%files tools
-%manifest msg-service-tools.manifest
-%license LICENSE.APLv2
-%config(noreplace) %{TZ_SYS_GLOBALUSER_DB}/.msg_service.db*
-%{_unitdir}/msg-server.service
-%{_unitdir}/multi-user.target.wants/msg-server.service
-%{_unitdir}/msg-server.socket
-%{_unitdir}/sockets.target.wants/msg-server.socket
-
 %files -n sms-plugin
 %manifest sms-plugin.manifest
 %license LICENSE.APLv2
@@ -288,15 +246,13 @@ setfacl -m group:priv_message_write:rw %{TZ_SYS_GLOBALUSER_DATA}/msg-service/ipc
 %license LICENSE.APLv2
 %{_libdir}/libmsg_mms_plugin.so
 
-%if "%{?profile}" == "mobile"
 %files -n msg-manager
 %manifest msg-manager.manifest
 %license LICENSE.APLv2
-%{APP_BINDIR}/msg-manager
-%{APP_MANIFESTDIR}/*.xml
+%{APP_PREFIX}/bin/msg-manager
+%{TZ_SYS_RO_PACKAGES}/*.xml
 %{APP_PREFIX}/author-signature.xml
 %{APP_PREFIX}/signature1.xml
 %{APP_RESDIR}/*
-%endif
 
 %changelog