Update SMACK rule
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
index 356d8a4..960cf2f 100644 (file)
@@ -1,9 +1,9 @@
 Name:       mobileap-agent
 Summary:    Mobile AP daemon for setting tethering environments
-Version:    0.1.81
+Version:    0.1.93
 Release:    1
 Group:      TO_BE/FILLED_IN
-License:    Apache License Version 2.0
+License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(dbus-glib-1)
@@ -16,6 +16,7 @@ BuildRequires: pkgconfig(libssl)
 BuildRequires: pkgconfig(secure-storage)
 BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(capi-network-bluetooth)
+BuildRequires: pkgconfig(appcore-common)
 BuildRequires: cmake
 Requires(post): /usr/bin/vconftool
 Requires: iptables
@@ -27,12 +28,10 @@ Mobile AP daemon for setting tethering environments
 %setup -q
 
 %build
-export CFLAGS+=" -fpie"
-CFLAGS="${CFLAGS}" cmake . -DCMAKE_INSTALL_PREFIX="%{_prefix}"
+%cmake .
 make %{?jobs:-j%jobs}
 
 %install
-rm -rf %{buildroot}
 %make_install
 
 %post
@@ -43,11 +42,38 @@ rm -rf %{buildroot}
 
 %files
 %manifest mobileap-agent.manifest
+/opt/etc/smack/accesses.d/mobileap-agent.rule
 %defattr(-,root,root,-)
-/usr/share/dbus-1/services/com.samsung.mobileap.service
+/usr/share/dbus-1/services/org.tizen.tethering.service
 %{_bindir}/mobileap-agent
 
 %changelog
+* Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.86-1
+- Fix the multiple notification issue
+- Support i80211n
+- Channel is changed to 6
+- Implement status notification for bluetooth visibility
+- Change the power manager api
+- Implement connection timer
+- Reference count is used
+- Support Mobile AP
+
+* Sat Feb 16 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.85-2
+- Function return value is checked
+- Private SSID is considered
+- Build option clean-up and g_type_init is deprecated from glib 2.35
+
+* Thu Feb 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.84-1
+- User is specified in service file for Dbus auto activation
+
+* Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.83-1
+- Remove unrequired log
+
+* Thu Jan 24 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.82-1
+- Indications for Wi-Fi tethering setting change are added
+- DNS Forward and Use of Tethering cellular profile are removed
+- Dbus service / interface / object names are changed
+
 * Mon Jan 14 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.81-1
 - dhcp lease delete is handled based on IP Address
 - DNS Forward by netfilter is implemented