tizen 2.4 release
[framework/connectivity/mobileap-agent.git] / packaging / mobileap-agent.spec
index 077d62b..0d9f566 100644 (file)
@@ -1,12 +1,17 @@
 Name:          mobileap-agent
 Summary:       Mobile AP daemon for setting tethering environments
-Version:       1.0.17
+Version:       1.0.36
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
 Source0:       %{name}-%{version}.tar.gz
+
+%if "%{?tizen_profile_name}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
 BuildRequires: pkgconfig(dlog)
-BuildRequires: pkgconfig(dbus-glib-1)
+BuildRequires: pkgconfig(gio-2.0)
 BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(gthread-2.0)
 BuildRequires: pkgconfig(deviced)
@@ -24,7 +29,9 @@ BuildRequires:        pkgconfig(appsvc)
 BuildRequires: pkgconfig(libssl)
 BuildRequires: cmake
 Requires(post):        /usr/bin/vconftool
+%if "%{?tizen_profile_name}" != "tv"
 Requires(post):        bluetooth-agent
+%endif
 Requires(post):        ss-server
 Requires:      iproute2
 Requires:      iptables
@@ -43,6 +50,12 @@ export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
 
 %cmake -DCMAKE_BUILD_TYPE="" \
+%if "%{?tizen_profile_name}" == "tv"
+       -DTIZEN_TV=1 \
+%endif
+%if "%{?tizen_target_name}" == "Z300H"
+       -DTIZEN_WLAN_BOARD_SPRD=1 \
+%endif
        .
 
 make %{?jobs:-j%jobs}
@@ -52,18 +65,15 @@ make %{?jobs:-j%jobs}
 %make_install
 
 %post
-/usr/bin/vconftool set -t string memory/private/mobileap-agent/ssid "" -u 0 -i -f -s system::vconf_network
-/usr/bin/vconftool set -t int memory/mobile_hotspot/connected_device "0" -u 0 -i -f -s system::vconf_network
-/usr/bin/vconftool set -t int memory/mobile_hotspot/mode "0" -u 0 -i -f -s system::vconf_network
-/usr/bin/vconftool set -t int db/mobile_hotspot/security "1" -u 5000 -f -s system::vconf_network
-/usr/bin/vconftool set -t int db/mobile_hotspot/hide "0" -u 5000 -f -s system::vconf_network
+/usr/bin/vconftool set -t string memory/private/mobileap-agent/ssid "" -u 0 -i -s system::vconf_network
 
 /bin/chmod +x /opt/etc/dump.d/module.d/tethering_dump.sh
 
 %files
 %manifest mobileap-agent.manifest
 %defattr(-,root,root,-)
-/usr/share/dbus-1/services/org.tizen.tethering.service
+/usr/share/dbus-1/system-services/org.tizen.tethering.service
+
 %{_bindir}/mobileap-agent
 /opt/etc/dump.d/module.d/tethering_dump.sh