Fix build break issue
[platform/core/appfw/message-port.git] / packaging / message-port.spec
index 11c4aff..0ce9cb6 100644 (file)
@@ -18,7 +18,6 @@ BuildRequires:  pkgconfig(gmock)
 
 %if 0%{?gcov:1}
 BuildRequires:  lcov
-BuildRequires:  zip
 %endif
 
 Requires(post): /sbin/ldconfig
@@ -83,22 +82,10 @@ mkdir -p "$gcno_obj_dir"
 find . -name '*.gcno' -exec cp --parents '{}' "$gcno_obj_dir" ';'
 %endif
 
-%check
-export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir}/
-ctest -V
-
-%if 0%{?gcov:1}
-builddir=$(basename $PWD)
-gcno_obj_dir=%{buildroot}%{_datadir}/gcov/obj/%{name}/"$builddir"
-mkdir -p "$gcno_obj_dir"
-find . -name '*.gcno' -exec cp --parents '{}' "$gcno_obj_dir" ';'
-%endif
-
 cat << EOF > run-unittest.sh
 #!/bin/sh
 setup() {
     echo "setup start"
-    %{_aulresdir}/tpk/install.sh
 }
 
 test_main() {
@@ -122,6 +109,15 @@ EOF
 mkdir -p %{buildroot}%{_bindir}/tizen-unittests/%{name}
 install -m 0755 run-unittest.sh %{buildroot}%{_bindir}/tizen-unittests/%{name}/
 
+%check
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:%{buildroot}%{_libdir}/
+ctest -V
+
+%if 0%{?gcov:1}
+lcov -c --ignore-errors graph --no-external -b . -d . -o %{name}.info
+genhtml %{name}.info -o out --legend --show-details
+%endif
+
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig