Disable build gbm
[platform/upstream/mesa.git] / packaging / mesa.spec
index 2f2140d..3656ecc 100644 (file)
@@ -39,6 +39,8 @@ ExclusiveArch:
 %define USE_VULKAN 0
 %define VULKAN_DRIVER broadcom
 
+%define USE_GBM 0
+
 %description
 Mesa is a 3-D graphics library with an API which is very similar to
 that of OpenGL.* To the extent that Mesa utilizes the OpenGL command
@@ -72,8 +74,12 @@ meson --prefix %{_prefix} build/ \
                -Dgallium-xvmc=false \
                -Dglx=disabled \
                -Ddri3=false \
+%if "%{USE_GBM}" == "1"
                -Dgbm=true \
-               -Dplatforms="tizen,wayland,drm" \
+%else
+               -Dgbm=false \
+%endif
+               -Dplatforms="tizen" \
 %ifarch %ix86 x86_64
                -Dgallium-drivers="i915,swrast" \
                -Ddri-drivers="" \
@@ -84,6 +90,7 @@ meson --prefix %{_prefix} build/ \
 %endif
                -Dgallium-drivers="vc4,v3d,kmsro,swrast"
 %endif
+
 ninja -C build/
 
 %install
@@ -118,7 +125,9 @@ cp 99-GPU-Acceleration.rules %{buildroot}%{_udevrulesdir}
 %{_hal_libdir}/driver/*
 %{_hal_libdir}/dri/*
 %{_libdir}/dri
+%if "%{USE_GBM}" == "1"
 %{_libdir}/libgbm*
+%endif
 %if "%{USE_VULKAN}" == "1"
 %{_hal_libdir}/libvulkan_%{VULKAN_DRIVER}.so
 %{_libdir}/libvulkan_%{VULKAN_DRIVER}.so