[Release] livebox.web-provider-1.54
[platform/framework/web/web-provider.git] / packaging / livebox.web-provider.spec
index 76dbdde..b9eaeb0 100755 (executable)
@@ -1,6 +1,7 @@
+#git:framework/web/web-provider
 Name: livebox.web-provider
 Summary: web framework for livebox 
-Version: 1.26
+Version: 1.54
 Release: 1
 Group: main/app
 License: Flora License, Version 1.1
@@ -26,14 +27,6 @@ BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(json-glib-1.0)
 BuildRequires: pkgconfig(capi-appfw-application)
 
-# requires for smack
-# We need to add smack dependancies here on specific criteria
-Requires(post): sys-assert 
-Requires(post): busybox-symlinks-sysklogd
-Requires(post): data-provider-master
-Requires(post): isf
-Requires(post): e17 
-
 %description
 This is web framework responsible to manage liveboxes that consist of web contents
 
@@ -49,9 +42,15 @@ Web Provider library (dev)
 %setup -q
 
 %build
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
+export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
+%endif
+
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_PROJECT_VERSION=%{version}
 #-fpie  LDFLAGS="${LDFLAGS} -pie -O3"
-CFLAGS="${CFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
+CXXFLAGS="${CXXFLAGS} -Wall -Winline -Werror -fno-builtin-malloc" make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
@@ -81,6 +80,8 @@ chmod 755 %{app_data}
 %{_prefix}/apps/livebox.web-provider/bin/web-provider
 %{_datarootdir}/packages/livebox.web-provider.xml
 %{_prefix}/share/res/*
+%{_sysconfdir}/smack/accesses.d/livebox.web-provider.rule
+%{app_data}
 
 %files devel
 %defattr(-,root,root,-)