Bump to libxml2 2.9.7
[platform/upstream/libxml2.git] / packaging / libxml2.spec
index ea441b8..9bc034f 100644 (file)
@@ -1,7 +1,12 @@
-%define lname libxml2
+
+%if "%{run_tests}" == "1"
+    %define __spec_check_pre %___build_pre
+       %define check %%check
+%endif
+
 
 Name:           libxml2
-Version:        2.8.0
+Version:        2.9.7
 Release:        0
 Summary:        A Library to Manipulate XML Files
 License:        MIT
@@ -10,7 +15,7 @@ Url:            http://xmlsoft.org
 # Source ftp://xmlsoft.org/libxml2/libxml2-git-snapshot.tar.gz changes every day
 Source:         ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
 Source2:        baselibs.conf
-Patch0:         fix-perl.diff
+Source1001:    libxml2.manifest
 BuildRequires:  pkg-config
 BuildRequires:  readline-devel
 BuildRequires:  xz-devel
@@ -42,8 +47,8 @@ This package contains xmllint, a very useful tool proving libxml's power.
 
 %package devel
 Summary:        Include Files and Libraries mandatory for Development
-Group:          Development/Libraries/C and C++
-Requires:       %{lname} = %{version}
+Group:          Development/Libraries
+Requires:       %{name} = %{version}
 Requires:       %{name}-tools = %{version}
 Requires:       glibc-devel
 Requires:       readline-devel
@@ -54,31 +59,9 @@ Requires:       zlib-devel
 This package contains all necessary include files and libraries needed
 to develop applications that require these.
 
-%package doc
-Summary:        A Library to Manipulate XML Files
-Group:          System/Libraries
-Requires:       %{lname} = %{version}
-BuildArch:      noarch
-
-%description doc
-The XML C library was initially developed for the GNOME project. It is
-now used by many programs to load and save extensible data structures
-or manipulate any kind of XML files.
-
-This library implements a number of existing standards related to
-markup languages, including the XML standard, name spaces in XML, XML
-Base, RFC 2396, XPath, XPointer, HTML4, XInclude, SGML catalogs, and
-XML catalogs. In most cases, libxml tries to implement the
-specification in a rather strict way. To some extent, it provides
-support for the following specifications, but does not claim to
-implement them: DOM, FTP client, HTTP client, and SAX.
-
-The library also supports RelaxNG. Support for W3C XML Schemas is in
-progress.
-
 %prep
 %setup -q
-%patch0
+cp %{SOURCE1001} .
 
 %build
 %configure --disable-static \
@@ -97,37 +80,41 @@ progress.
 make %{?_smp_mflags} BASE_DIR="%_docdir" DOC_MODULE="%name"
 
 %check
-# qemu-arm can't keep up atm, disabling check for arm
-%ifnarch %arm
-make check
-%endif
+rm -f /tmp/%{name}_test
+%__make runtests | tee -i /tmp/%{name}_log
+cat /tmp/%{name}_log | grep "^TEST: " > /tmp/%{name}_test
+chmod +x ./run_test.sh
+./run_test.sh %{name} %{version}
+rm -f /tmp/%{name}_log
+
 
 %install
 make install DESTDIR="%buildroot" BASE_DIR="%_docdir" DOC_MODULE="%name"
-mkdir -p "%buildroot/%_docdir/%name"
-cp -a AUTHORS NEWS README COPYING* Copyright TODO* %{buildroot}%{_docdir}/%{name}/
 ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml
 
+%remove_docs
 
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
-%files 
+%files
+%manifest %{name}.manifest
 %defattr(-, root, root)
+%license Copyright
 %{_libdir}/lib*.so.*
-%doc %dir %{_docdir}/%{name}
-%doc %{_docdir}/%{name}/[ANRCT]*
 
 %files tools
+%manifest %{name}.manifest
 %defattr(-, root, root)
+%license Copyright
 %{_bindir}/xmllint
 %{_bindir}/xmlcatalog
-%doc %{_mandir}/man1/xmllint.1*
-%doc %{_mandir}/man1/xmlcatalog.1*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-, root, root)
+%license Copyright
 %{_bindir}/xml2-config
 %dir %{_datadir}/aclocal
 %{_datadir}/aclocal/libxml.m4
@@ -138,16 +125,6 @@ ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml
 %{_libdir}/libxml2.la
 %{_libdir}/*.sh
 %{_libdir}/pkgconfig/*.pc
-%doc %{_mandir}/man1/xml2-config.1*
-%doc %{_mandir}/man3/libxml.3*
-
-%files doc
-%defattr(-, root, root)
-%{_datadir}/gtk-doc/html/*
-%doc %{_docdir}/%{name}/examples
-%doc %{_docdir}/%{name}/html
-# owning these directories prevents gtk-doc <-> libxml2 build loop:
-%dir %{_datadir}/gtk-doc
-%dir %{_datadir}/gtk-doc/html
+%{_libdir}/cmake/libxml2/libxml2-config.cmake
 
 %changelog