Generate new keysyms although profile is common
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
index 2f5dea9..94cc05c 100644 (file)
@@ -1,24 +1,27 @@
 Name:           libxkbcommon
-Version:        0.3.0
+Version:        0.4.3
 Release:        0
 License:        MIT
 Summary:        Wayland libxkbcommon library
 Url:            http://wayland.freedesktop.org/
 Group:          Development/Libraries
 
-#Git-Clone:    git://anongit.freedesktop.org/xorg/lib/libxkbcommon
-#Git-Web:      http://cgit.freedesktop.org/xorg/lib/libxkbcommon/
 Source:         %{name}-%{version}.tar.xz
-Source1001:    libxkbcommon.manifest
+#X-Vcs-Url:     https://github.com/xkbcommon/libxkbcommon.git
+Source1001:     libxkbcommon.manifest
 BuildRequires:  autoconf >= 2.60
 BuildRequires:  automake
 BuildRequires:  bison
 BuildRequires:  flex
 BuildRequires:  libtool >= 2
-BuildRequires:  pkgconfig
-BuildRequires:  pkgconfig(kbproto) >= 1.0.4
 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
-#BuildRequires:  pkgconfig(xproto)
+%if "%{?profile}" == "common"
+%else
+BuildRequires:  python
+BuildRequires:  xkb-tizen-data
+%endif
+
+%global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
 
 %description
 Keyboard handling library using XKB data.
@@ -26,7 +29,7 @@ Keyboard handling library using XKB data.
 %package devel
 Summary:        Development files for the Wayland libxkbcommon library
 Group:          Development/Libraries
-Requires:       %{name} = %{version}
+Requires:       %{name} = %{version}-%{release}
 
 %description devel
 Keyboard handling library using XKB data.
@@ -38,14 +41,25 @@ in %{name}.
 %setup -qn %{name}
 cp %{SOURCE1001} .
 
+# Generate tizen keymap header except common profile
+export TIZEN_PROFILE="%{?profile}"
+export TZ_SYS_RO_SHARE="%{TZ_SYS_RO_SHARE}"
+chmod a+x ./make_tizen_keymap.sh
+./make_tizen_keymap.sh
+chmod a+x ./gen_tables.sh
+./gen_tables.sh
+
 %build
-%autogen
-%configure --disable-static
-make %{?_smp_mflags} V=1;
+%autogen --disable-static --disable-x11 --with-tizen-profile="%{?profile}"
+%__make %{?_smp_mflags} V=1;
 
 %install
 %make_install
 
+#for license notification
+mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
+cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
+
 %post  -p /sbin/ldconfig
 
 %postun  -p /sbin/ldconfig
@@ -53,7 +67,7 @@ make %{?_smp_mflags} V=1;
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root)
-%license COPYING
+%{TZ_SYS_RO_SHARE}/license/%{name}
 %{_libdir}/libxkbcommon.so.0*
 
 %files devel
@@ -63,4 +77,3 @@ make %{?_smp_mflags} V=1;
 %{_libdir}/libxkbcommon.so
 %{_libdir}/pkgconfig/xkbcommon.pc
 
-%changelog